Whole numbers error

I’ve seen multiple threads about the whole number issue and they’re marked as resolved but I’m trying to approve service hours and I’m getting the whole number error. If a scout only gets 0.5 hours I don’t want to give them 1 hour.

This is a known issue. I will try to get a scheduled fix date on it


A related question - when entering miles for a hike, I am also prompted to input a whole number rather than a partial number. For example, I wanted to enter a hike two of my sons did yesterday. It was 6.6 miles but I had to round it up to 7 for it to be accepted.

It may not matter as much for hiking as it does for service hours, but if I have to keep rounding to the nearest whole number, over time that could mean a lot of miles gained or lost depending on which way I have to round.

I am pretty sure this but has not been fixed yet (I didn’t see it mentioned in recent change logs), but just in case it was and I missed the memo, I too am having this error appear.

I tried to enter and approve a hike done yesterday and was prevented from approving it for not having a whole number entered into the data field.

I don’t know if this will work for everyone but I found a potential work around until the bug is fixed.

I changed the miles to be a whole number, in this case rounded up from 6.94 to 7 and then approved the hike. Afterward, I went back in to IA, opened the activity, and under the advanced tab, changed the mileage to the correct amount. When I saved that, I did not receive any errors.

I also noted the original total miles hiked on the screen before I made the adjustment. It was 17.8. After I edited the most recent hike to show 6.94 miles instead of 7, the miles total miles hiked correctly shows 24.74 miles.

If I have need to enter any hikes before the bug is fixed, I’ll try entering the miles only on the advanced tab to see if doing it that way bypasses the whole number error issue altogether.

@S.G In Internet Advancement, have you tried entering activities by:

  1. Start on the Roster page
  2. Select all attendees
  3. Click on Record Progress
  4. Click on Hike

then create the activity. I was able to add a hike this way a few days ago with mileage that was not a whole number, and I had no problems.

The hike yesterday was not a unit hike. It was a hike my son did with me and his dad. The previous hike I mentioned in this thread was also not a unit hike even though four of the participants are in my Troop (my 2 sons and my friend’s 2 sons).

For activities that are not a Unit Activity, I don’t think using the Roster to add attendees will work because it defaults to the event being a Unit Activity. I don’t see a way to specify that the activity is a non-unit event when it’s created by a Unit Leader.

The solution I offered may be a way for leaders to approve hikes that the scout completed on their own rather than with their unit. The hike that my son did was entered through his account, but when approval was required, the whole number issue came up. There was no problem creating the hiking activity and entering in the 6.94 miles as part of the entry. It was only an issue when trying to approve the hike.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.