BOY SCOUTS OF AMERICA

Scouting Forums

Imported Merit badge data from camp, some don't show 100% complete

We imported merit badge data from a summer camp .csv export file and found that even though we had scouts that completed all the requirements for Archery, Environmental Science, Automotive Maintenance and Law, and the requirements were correctly imported into scoutbook, the percent complete calculation shows more work to do and the merit badge does not show up as complete. When you look at the requirements, all the boxes are blue or grey which indicates that all the necessary requirements are done.

It looks as if the complete calculation is expecting every option to be done, even though the actual portion with the individual requirements thinks it is done (all complete and/or grey). Is there any way to correct this or do we manually have to override and say the merit badge is complete?

that blackpug file has a separate “COMPLETED” field - if that was not marked I imagine that is the issue

Thank you!

Maybe there is a format issue? I opened the csv file and saved it as an excel file. Here is a screenshot of the lines saying it should have been approved:

Is there a formatting thing I should check?

I should note that it has the columns for the Unit, BSA Member ID, and names. I just didn’t include them in the screenshot. I did not edit anything in the csv, and they were imported from the csv. But making an excel copy makes verifying a lot easier.

If it was missing the approval entry, I’m still not sure why it wouldn’t calculate 100% but then say it wasn’t approved? That seems like the most logical thing since all items were complete.

I appreciate the help.

using the csv - I just went back and added what was marked approved with QE

So where it has approved as a 1 change the 1’s to QE? The ones that worked had a 1 in that column too. I probably don’t have enough samples to say, but either a merit badge worked or it didn’t. These ones calculated correctly and approved:
image

no @TamarEverard - “1” means YES - so it was marked APPROVED - use Quickentry where Advancement Type=Merit Badge (that means the whole Merit Badge - not Merit Badge Requirement) and it is marked “1” - that means the whole MB was marked approved. Use the Scoutbook Quickentry system to mark them approved.

Thank you! I understand what you are saying now. I’m new to this, do you know if there is a way to report this so they get the calculation corrected? Not being able to trust the import means a lot of auditing. I’m not sure who to talk to.

For now though, I will do as you suggest and do the quick entry to get the approvals in.

Thanks!

the Extension author pointed out a number of issues to Blackpug that I found - if you document them here I will make sure he sees those as well

Thank you. Can someone check scoutbook as well? This happened to a couple items when I entered manually in cub scouts. One I think was the outdoor award for one of the ranks. But I didn’t write it down. Just want to make sure we find the real root cause. On the surface it seems like the approval was blocked because it wasn’t 100% complete.

Anyway, I appreciate your help!

some cub things do not auto complete when they hit 100% - you still have to manually put in a date

So even though it doesn’t say 100% it is still complete, you just need to approve it? It gets confusing because I kept looking at the requirements wondering what still needed to be done since everything else goes to 100%.

So I found something. It may be Scoutbook. I tried the incomplete merit badge report, and it says that archery has missing requirements, and lists 5A, even though you only need A OR B, and says 5B even though under 5(B)(f) you only need one option.
image

@TamarEverard - it would seem to be a calc issue especially if it shows less than 100% on an obvious completion.

I have reproduced that issue in Scoutbook. It has nothing to do with the import. We will report this to the developers.

2 Likes

Thank you very much.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.