Internet Advancement Unavailable/Broken for Scouts within My Den

I have been unable to advance the majority of my Den. I managed to advance my own son about a week ago and one other child, but since then the advancement page that I need (Webelo) fails to load properly for the Scouts who have not been advanced.

Is this a known issue? Is there a workaround?

Here are some additional details:

  • I can view the other rank pages (e.g. Bear, Tiger, AOL) for those same Scouts.
  • I have tried Chrome, Firefox, and Edge.
  • I have tried over the course of multiple days and different times of the day
  • When I go to the Webelo advancement page for Scouts in other Dens, the page does load
  • When I go to the Webelo page for the two Scouts in my Den that I have already advanced, the page does load
  • The attached images are both from the same Scout in my Den. The images are the same for all Scouts in my Den who have not been advanced - other ranks can be viewed, and I assume modified, but Webelo cannot.

@AlexCope this is a known issue that arose this week

1 Like

I am having a similar issue with a couple new Bears. Do we know when it will be fixed?

no timeline - there is a work around - look at the URL - there is a scout number …/###### - if you add /adventures to the url after the number it takes you to adventures page - click Show all and you can get to the adventures you need

1 Like

Hi, I was able to add the Adventures but the scout’s percentage of completion did not change and I am still am unable to approved his AOL rank.

I have the same issue. I am unable to update my scouts with current info on adventures finalized. This is in regards to AOL- message is “This Advancement has no requirements.”
I’ve already been able to input 56% on most of my den so I hope that information is able to be retrieved.

Did you try the suggested work around?

I did the hard refresh with no luck.
I was able to input info using quick entry from the older version but not able to see it. System just says it was updated.

@ChristineFinnie The suggested workaround is from post 4 of this thread:

I tried the workaround just now (1549 EDT 2 July 2024) and it did not work. It just took me back to the Scout’s page.