“Loading” then error when trying to access a scout

I can navigate through the troop in Scout book except when I click on any Scout it says “loading” for a long period of time and then I get an error message. I am an admin, but I can’t click on any scout even my own child. I have tried rebooting my phone and closing every tab. I have logged out completely and
logged back in. Nothing works. This is a new issue as I was in Scoutbook just a few days ago.

1 Like

I’m having this same exact issue. Came back from a backpacking trip, wanted to get all the requirements logged that I signed off for scouts and am unable to access any scout in the troop. I can navigate through the troop but it won’t load any scouts. I receive a loading notification that times out and then ends with an error.

We are getting the same error. When I click on “My Account”, it errors out.

1 Like

I’m getting the same error.

1 Like

Same here error here.

I am also getting the same error

Getting the same error here in advancement once I select an individual.

I am experiencing same issue as of 8:00pm 6/30/2024

1 Like

It should work now.!

Scoutbook is working for me.

Are you all having issues in Scoutbook? Or Scoutbook Plus?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.