Roster is not loading

Is Scoutbook down? I am able to log in to the Scoutbook homepage, but I am unable to load the roster from my troop. It eventually pops up with “error loading.” I have tried clearing history and cache in my Chrome browser, but no go. Just tried it again and now the main page isn’t even loading.

I’m not able to do anything in Scoutbook tonight either. An hour or so ago, it wouldn’t load due to a server error. Now I can log in and reach the dashboard, but anything else will just load for awhile and then show “Error loading page.”

EDIT: I was just now able to reach the MB counselors’ quick entry page, which doesn’t require any unit data. I wonder if that’s the problem. I see in my developer tools that the request for data from unit.asp immediately returns a gateway timeout error.


Same. Can’t get anywhere on MyScouting either.

There are issues with multiple BSA systems tonight. BSA IT is investigating but at least some of the probelms appear to have been resolved. I am now able to login to Scoutbook and the system is usable.

If you have an open session, go all the way back to the login screen ( and log in again.

I tried clearing out everything, exited Chrome, came back and tried to log in again. I can get to the Scoutbook homepage, then the troop’s page, but I still can’t open my troop roster.

It’s a different problem now in the dev tools:
GET 404 (Not Found)
(was a Gateway Timeout before)

This is when trying to loading my unit from the dashboard. It’s an immediate fail.

Now it’s just down for maintenance. I will try again tomorrow and give the devs time to resolve it.

Oh, I see that now too. 404. Good idea to just wait til tomorrow.

Scoutbook has been running much better the next morning. The site has been up and running fairly fast.


Everything is working much better on my end, except for the dreaded yellow triangles showing up for our leaders in the roster. But someone already posted about that and National is aware of it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.