Looking up merit badges in Scout book still not working

As a council employee with permissions I still can’t look up merit badge counselors in Scout book. Any word yet on a fix for this problem. The yellow bar mentioning problems with user searches is gone but the problem still persists.

Turn the Extension off.

What does that mean?

Check your browser extensions and make sure they are turned off. If that doesn’t solved the problem, give us exact steps leading to the issue.

I did that and it still is not working. My steps to look up a merit badge counselor:
I click on Google
click on the Scout book site I have bookmarked
Log into Scout book
Click on My Dashboard
Click on MB List
I enter First and Last Name
remove the zip code and hit enter
I get this error message: Whoops! We encountered an error trying to process your request.

Our webmaster has been notified and will fix it ASAP!
What am I doing wrong?

@MichelleBaumann - and that site would be scoutbook.scouting.org?

I have found that if I follow the above steps but do not delete the zip code it works. It worked before when I deleted the zip code. Sorry for raising the flag on this issue.

It searches by proximity to zip code, so it is kind-of important for the search


Whoops is bad. We will report this to the developers. If zip code is omitted, per the page, the sort is alphabetical.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.