MB Counselor shows in search, but not when trying to make new connection for Scout

I have made multiple connections for a MB counselor in our Troop, and he has been able to work in SB to record advancement. But the search function no longer works to pull up a connection for him with new Scouts who have started the same MB. I can find him in the general MB Counselor search tool, but not in the Scout-specific MB New Connection function. Not sure how I can do this, but I took screen shots to show how the counselor is available in search, and how I enter the same information into the Add Connection search function and get no hits.

Is he already in the scouts connections. You would add more permissions through there.

He is not currently connected to the new Scouts that he started working with. If there is a way to upload screen shots I can show you how weird the error is.

If the MBC is an adult leader in your troop, then you should be able to use the Connections Manager to make the initial connection.

Then you would go to each Scout’s Connections page to update the connection type as MBC for the particular merit badge.

1 Like

With the recent change in fee structure for adult leaders we now have a number of MBCs who are only registered as MBCs. This also means they are no longer through our Troop, but through the District, so they don’t show up on our roster anymore.
But I want to reiterate that this counselor can be found in SB when doing a search for MBCs. He shows up with that particular Merit Badge. So he is registered, and is in the system. But when doing the Add Connection he does not show up in the search that way.
I have had a lot of trouble with the Add Connection search in SB in general. It has been changed and no longer works as easily or as intuitively. In the past the Invite Counselor button went directly into a list of counselors registered for that MB listed by distance from the Scout. Now it goes into the Add Connection screen, requires at least two pieces of identifying information, and most recently, returns the message “No record found that satisfies the search criteria.”
BTW I have tried this for a different Scout with the same MBC, getting the same return message. I then tried a third Scout, with a different MBC, and also got the same return message. These errors started cropping up after the Invite Counselor function was changed to Add Connection.

Are they parents? If so, they should show up in the Connections Manager and you can connect them.

Post the MBCs and the Scouts BSA#/MID (no names) and we can take a look

Here we have yet another challenge. Now that these MBCs are no longer in our Troop, but registered with the District, I don’t have ready access to their BSA IDs. In the MBC Search they come up with names and email addresses, not BSA IDs

Can I send you screen shots so that you can see what I am looking at and what I enter into the search fields? Maybe there is an entry issue. Maybe SB is looking for last name first. I am simply at a loss right now. It was so easy, and I connected all Scouts to their MBCs in the past. But this recent change has become a tough hurdle to overcome, negating all the effort I’ve made in the Troop to switch all MBC to using electronic entry. Of course this is in self-interest - I am the Advancement Chair and don’t enjoy spending hours entering Blue Car information manually into the system. But electronic entry also benefits the Scouts and the Troop because we know where Scouts are in their Advancement.

I will send you a direct message > look at top right Avatar to find it > it will be a green envelope > it will be a private message channel with select members of the Scoutbook User Advisory Council (SUAC)

MBCs can also add the connection themself under my connections

I’m taking baby steps with the MBCs. First goal is to get them to enter MB progress into SB. Next step, working on now, is using SB to communicate with the Scouts. I’ve tried to take on more of the admin work myself so their job is easier. We have already lost some MBCs because of the new fee and training requirements. I don’t want to lose the rest.

If the MBC selects the My Positions tab under their profile, and marks themselves as “Busy”, they will not show up in the Lookup/Invite List if you have “Available” selected in your criteria.

De-select “Available” on the upper left, hit refresh, and see if you can see them then. Their profile there should be marked with a yellow BUSY box.

The availability of the MBC is also not the issue. I know the MBC is available, and availability is not what was throwing up the error. It seems that the MBC search is not as “forgiving” with the data required as the instructions suggest. In fact, the MBC search did not work at all. I worked with @DonovanMcNeil and through trial and error we discovered that the best way of finding an MBC is to NOT check the “Include MBC Only” box, and when searching to also include the MBC’s BSA ID. So while instructions suggest that the name is the only required field, plus a choice of others that may not necessarily include the BSA ID, in fact the search was only successful when the BSA ID was included.

I have seen the exact opposite at times where they only appeared when checking that box.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.