Merit Badge Quick Entry not working

I posted more than a week ago, but the item was closed so I am following up to see if there is any update on this. When I attempt to use Quick Entry to post Merit Badge requirements completions, I get a “Whoops” error every time.

I have 35 Scouts who earned many MBs in summer camp to enter - any thoughts from the hive mind? This task is daunting already and this hiccup is a little …frustrating.

-Karen

Do any of the scouts have a pack membership in scoutbook?

No, I’ve only tried about 6-7 (of my 35) thus far and none of those have pack memberships. They are long standing Troop members (a few which are already Star or Life ranks).

usually a QE failure is membership based - one other thing to try is to reset your admin position

Go to unit Roster in Scoutbook > Click your name > click Admin > click Update - it has to be these steps and path

If that does not resolve it we can setup a screenshare to take a look

I did this (I assumed you meant “Troop Admin” when you said Admin), but I still get the Whoops error.

Can I schedule a time with you tomorrow morning to do the screenshare? I’m pretty flexible until noon.

Friday morning is no good for me

Donovan - So, I’ve found that I can (once) perform QuickEntry from the initial screen, but if I’m in the Roster, or a Patrol and choose that option I get the “Whoops” error. I have not attempted to repeat the success (I ran out of time!) but I will advise what I find going forward.

-Karen

I discovered while using QE for Summer Camp data entry that even though QE says it successfully completed the entries that it randomly misses a few entries for some of the scouts when doing a group credit. I have had to go back and check each individual and manually add any data I see missing.

Have you checked what @DonovanMcNeil mentioned above regarding the presence of pack-level memberships in Scoutbook for the affected scouts?