Quick Entry in Scoutbook give me a "Whoops"

I’m attempting to enter my Troop’s summer camp merit badge completions/work. I’m on the first Scout - Space Exploration - and I’m using the quick entry feature in Scoutbook. I have now attempted it 4 (perhaps 5?) times. Each time I get a “Whoops”. I’ve tried backing completely out, I’ve tried a hard refresh of the page, I’m not sure what else to do.

I am the Advancement Coordinator for my Troop and have 35 Scouts (with at least 4-5 merit badges each) to complete, so anything that can be done to assist me would be greatly appreciated!

Karen Rodman

First I would make sure all new scouts do not have open pack memberships in Scoutbook @KarenRodman

1 Like

Thanks for the idea…this Scout definitely doesn’t - he’s a Life Scout and already has many many MBs.

We have a few new Scouts, so I will verify for sure when I get to them (although would that prevent them from being able to earn MBs in our Troop since they’ve crossed over months ago)?

I’m having the same issue with some of my Cub Scouts. I’m having issues entering both bulk and individual scout adventures from camp.

@AmberJohns what is the error you are getting

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.