Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Message: You Do Not Have Access to this API

I am suddenly getting this message “You do not have access to this API” when I open Application Manager in My.Scouting. Since I am the Pack Committee Chair and the Charter Organization Rep, and recently processed applications, I do not understand why I get this message. What should I do about it?

Side comment: my.scouting and IA need to spend more effort on their error messages. They are too cryptic.

It might be related to the BSA’s data center relocation.

1 Like

And the legendary “Whoops” In Scoutbook.

And more importantly the forums remain untouched so that the community can complain without having to wait.

The forums are in a SaaS product, not in BSA’s data center.

I’m having the same problem. Committee Chair, can’t access application manger, same error.

Since there was a data center relocation over the weekend, I will recommend that everyone clear their cache first - then re-try accessing the API. (It also helps if you use Incognito Mode, or a Private Browsing window.) So, please, do that first, and then let us know if the issue persists.

I tried an InPrivate window (using Edge), that did not help. I tried using Chrome, also did not help. Can I clear my cache without wiping out all my remembered passwords?

@JosephKeller1 - clearing cache is not involved with saved passwords. That is stored as a file.

You need to clear cache before you use a Private browsing window (for best results). Here is how to clear cache on most of the major browsers:

OK, using Chrome, I cleared the cache, and opened an incognito page. Same error message, and the Application page does not complete loading.

@JosephKeller1 are you trying to get into Troop or pack?

@RonaldBlaisdell - ok… I decided to try this myself and I get the API warning as well and spinner in the alerts box and the unit info box above that.

@RonaldBlaisdell yes it is just sending 401 (Unauthorized) for all responses to Application Manager

If there are pending or open applications it seems you can still get to them

I am trying to access the Pack application manager. I am anticipating a couple applications.

on my District K3 I see the API error but I can also still “VIEW” applications

I have reported the error to BSA IT. (Added note: BSA IT already had an open ticket, but they were able to add the extra detail I provided, and increased the priority of the support ticket.)

2 Likes