My.Scouting new Adult Application fails with "Error Code: /phoneCountryId expected" error

When I try to fill out a New Adult Application for myself (for an additional role at the District level), using our District’s “Join” link from the Invitation Manager, I go through the registration steps of the flow and get to the final page where I’m writing my e-signature. However when I click “Go to Checkout Summary”, it throws an error saying:
Something went wrong
Error Code: /phoneCountryId expected type: Number, found: Null, Message: Bad Request

There are only two phone numbers in the application process: one for myself and one for my reference. I deleted and re-entered both of them, but the error persists.

Any suggestions?



(If you are reporting an issue with My.Scouting, please include all of the following items so we can better assist you:
1) Hardware: Desktop or Mobile (if mobile, please be specific)
2) Operating system
3) Browser
Chrome (latest)
4) Browser cache has been cleared or you are using a private browsing mode (aka Incognito Window in Chrome)
5) Member ID & Council of person affected
12864798 Golden Gate Area Council
Thank you!)

@PaulLanzi - the country code woulde be 1 for the north American dial plan. You need to include the 1.

Hm - I started over again (in an Incognito window) and added a ‘1’ this time to both phone numbers – same error. Any other suggestions?

@PaulLanzi - the phone number should be
County code - area code - exchange - extension

So 1-###-###-####
That is how the numbers work in telco. Now i will note that on line apps are not allowed in my council so mg only experience is in Telcom itself.

I am also not certain if incognito is the best option

Ah, yes – I also worked in telecom (SBC) for 8 years, so I understand how phone numbers work – I think there is something wrong with the validation logic that my.scouting is using to validate the phone numbers.

@PaulLanzi - i suggest your council open a ticket with national.