No red menu on Roster dashboard

I’ve watched the introduction video for Scoutbook Plus. I am trying to rank up my pack’s dens. When I get to the roster page, I don’t have the red menu across the middle that allows me to click on dens so I can edit them. I have a gray menu that says add individual, add den and unit quick entry. Below that is the roster with a red run report button. It feels like I am not in the right roster place on the site, but I don’t know how to get to the right spot.
I’ve restarted my computer, cleared my cache and done a hard refresh.
Thanks in advance!

@DawnGoodman1 - are you doing this on your phone… please use a pc.

No, I am doing it on my laptop.

@DawnGoodman1 - what browser and what role is selected in the upper right of the SB+ screen? Perhaps screenshots of what you are seeing would help.

What is your role in the unit ?

I am committee chair. Pack admin is selected. (I am also merit badge counselor for my older son’s troop, but I selected the pack.) I am using Microsoft Edge. Would using Google Chrome make a difference?

@DawnGoodman1 - i would try chrome or incognito session in edge

Using google chrome worked. Thank you so much for your help!

1 Like

@DawnGoodman1 - my pleasure. Would still suggest incognito or private session in edge to rule out add ins

I tried it to see and incognito in edge didn’t work either. I’m not sure why. At least chrome works, which is what is important.

@DawnGoodman1 - indeed if it works then perfect. I did try edge and I get the menu bar

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.