BOY SCOUTS OF AMERICA

Scouting Forums

Unable to see Scoutbook after login

I am able to login to Scoutbook, however, once I get tot he page with a list of tabs (My Dashboard, my.scouting, etc), no roster will come up. I can see it flash on the screen and then immediately return to that page.
I need to be able to enter new Scout achievements!

2 Likes

@NutushaCurren - what are you clicking on when you see the “flash” ? What is your role and position in the unit ?

1 Like

Cubmaster with access to all Scouts. I am clicking on “My Dashboard”

1 Like

@NutushaCurren - what device and browser are you using and has this worked for you prior ?

1 Like

Taking a wild guess, try resetting your Cubmaster and Pack Admin roles by going to:

My Dashboard → My Account → My Positions then click through to each of the positions.

In each position, tick the “I agree…” box and click “Update”

Normally, I recommend doing this via the unit roster, but since you can’t get the roster to display, maybe this will kickstart things.

1 Like

I can’t get to anything… when I click on My Dashboard, it circles right back to that page with My Dashboard, my.scouting Home page, Internet Advancement, etc

1 Like

Hrm…are you logging in with your email address or with your my.scouting credentials?

1 Like

It is doing the same thing no matter which device I use - mobile, laptop or PC.
I have never had an issue before

1 Like

try going to
https://www.scoutbook.com/mobile/dashboard/admin/account.asp

1 Like

@CharleyHamilton my.scouting credentials as I have signed up for the SSO option for my.scouting and Scoutbook login to be the same

1 Like

That was what I figured, but thought it was worth checking.

If you can’t get to the URL that @DonovanMcNeil suggested, try logging in to my.scouting and see what it shows as your positions there. We’re getting toward recharter time, and I’m wondering if your position somehow fell off the primary roster, and that fouled up the Scoutbook side of things.

1 Like

@DonovanMcNeil Okay, I was able to reach my profile from there, went in and clicked the “I agree…” box and update. Nothing…

1 Like

hold the SHIFT key and Refresh page.

Also try an Incognito/private browser window

1 Like

I am having a similar problem using Internet Explorer 11. I can log in, but when I select “Dashboard”, it flashes as if it’s going to the next page, but reverts back. As result I can’t select the unit (have more than 1 with SB access) or do anything else.
I can get in with Chrome and everything works fine.
I have checked for IE updates, setting changes, Windows updates, etc., but there are no records of any changes being made on my laptop. I have cleared Caches, disabled all Add-ins, etc. without effect.
It only happens on my laptop using IE 11. The mobile app and Chrome work OK still.
I did check out each role and tick off the “I agree to join Unit leader Roster” using the link that DonovanMcNeil posted, but it didn’t help.
My next step is to try a different computer and see if it’s device related / browser related or not.
Fortunately there are options for me…

PS: Just started today that I can think of. Was able to get in Monday fine. Don’t think I tried since then.

1 Like

IE is a very unstable browser for most websites that have a layer of complexity. Chrome or Firefox seem to work best for SB.

I am having the same issues??? What did SB change now that created an issue??

Most importantly…how do I fix it?

@CarrieHuot - are you attempting this in internet explorer if so please try another browser.

I am having the same issue. Once I log in, the dashboard flashes then nothing opens!

Are you using Internet Explorer? Don’t it is too unstable

This does appear to be an Internet Explorer issue, specifically Version 11.0.9600.19230 update 11.0.101 (4483187). I wasn’t having any issues before this week, but am seeing the same thing now. No problems with Chrome or Opera.

Note that both the IE version and update are several months old, and the issue only a few days old. As showed up around the same time as the Oct 31 SB update, I’m guessing something that was changed in that update is not compatible with IE.