Online Training Fails to Connect

I’m trying to start an online training course, several in fact, and all result in an error: This site can’t be reached

All of the links connect to, for example,, etc.

I have tried Windows and Macbook computers, Safari, Chrome and Firefox browsers. doesn’t answer a ping… What am I missing?

@JefferyGreen - here is where I find training:

I do have to ask where those links came from ?

Hi Stephen, I use the first link you have which displays a list of courses I should take. For example, the first on my list is ’ District Level Unit Service SCO_771 Take Course>'. Clicking on Take Course takes me to which then fails to open and a ‘Server Not Found’ error.

@JefferyGreen - here is the link I get for 771

It would appear that you have some odd re-direct happening. Please try an incognito window on the browser

Well that is interesting, following your link works just fine and gets me into the course catalog where I can start the training.

I tried the incognito window idea in Chrome and have the same result: ‘Take Course’ links to

Could there be regional servers and maybe ours has bad url’s?

@JefferyGreen - the PD makes me think personal development… which would be an internal employee thing. I would try starting out in

Weird since I am not and have never been an employee, it’s the most plausible guess though. I will use that link from now on, thanks for your help.

@RonaldBlaisdell - perhaps you can provide some insight?

They recommend that you use the most current version of Chrome or Edge. Other than that, I don’t see anything obvious.

Correct URL is not

1 Like

@RonaldBlaisdell - thanks for confirming. My curiosity is the redirect to trainingpd… I had provided the official links but the OP gets a re-direct to trainingpd… odd indeed

@JenniferOlinger - and forgot to ask that question and i would have gotten away with it if it were not for you meddling kids.

1 Like

@JenniferOlinger All browsers are up to date and the current version. Even an out of date browser wouldn’t explain the incorrect url link I see.

@RonaldBlaisdell The issue is when I am on this page My Scouting I see courses to complete and an option to start the course on the right where it says ‘Take Course >’. The ‘Take Course >’ text includes a link and every course link listed starts with ‘…’

The ‘trainingpd’ part of the url appears to be the issue as pointed out by Stephen.

For reference, here is a screenshot of the issue.

What position is this training for?

@RonaldBlaisdell I have course requirements for Asst. District Commissioner, Unit Commissioner and Assistant Council Commissioner. Each and every link under each position starts with ‘’.

Sorry if I’m asking redundant questions - these incorrect links where are they located, specifically, in my.scouting? (Which tool is showing them?)

@JefferyGreen - i have bounced around in the training site and i have yet to see where it presents the link with the course. I honestly think it is something local to your devices and configuration. Perhaps a larger screen shot or perhaps of the browser window itself

@RonaldBlaisdell It’s the Requirements page of My Training. This was brought up last year and I did my best to report it. Unfortunately like most things lately, it went into the pit of despair.