Pack admin can't create pack events

I was granted Pack Admin rights on Scoutbook before the switch to IA calendar. I have full access to Scoutbook and scout information. When using IA, I am not able to do the following:

  1. Create PACK events. I can only create den events for my den.
  2. Approve ACTIVITY logs for any scouts, including those in my den.

Any advice on how to remedy this?

@AngelaMcCormick make sure you have Pack Admin selected in the Profile Dropdown at top right. Also try a Shift + Refresh

1 Like

When I go to “Currently Viewing” dropdown menu, Pack Admin is not an option. Options are:

  1. Den Leader
  2. Merit Badge Counselor/Nova Counselor
  3. Parent
  4. Parent

Is that everything in the list after the forced reload @DonovanMcNeil suggested (i.e. shift+refresh)? If so, you can try “refreshing” your Pack Admin role by going to

My Dashboard → Administration → My Units → Pack XYZ → Roster → your name

then selecting your Pack Admin role, make sure it says “approved” and save.

Sometimes, things get fouled up behind the scenes somehow (it’s happened to me) and the unit admin role looks fine but is actually disconnected somehow in the background. This often resolves the issue, but is path-dependent, so you can’t just go the “short way” via My Positions. You might also need to perform a forced refresh in SB+IA afterwards to make it up the functional role.

Yep, did all that you recommended and it still is not working after force refreshing and restarting. I am working on a Mac. I will try another browser, but in the meantime, any other suggestions?

@AngelaMcCormick - are you using safari as your browser

Yes, I was. I changed to Chrome and that appears to work. Safari is my default browser and it is so annoying that so many things in Scoutbook and IA is not compatible with it.
Hopefully this was the fix I needed and will have to use this solely for scouting.
Thanks!

Safari is becoming less reliable across all the Web - Apple has not kept up

On my Mac, I use Chrome for SB because of the feature assistant extension and use Safari for just about everything else.

I’m having the exact same issue here. I’m on a PC and have tried this on both Firefox and Chrome. Neither is working. I’ve done the hard refresh, followed all ideas here.

When I’m on the calendar page I go to the Profile Dropdown and I only see New Member Coordinator as an option for “Currently Viewing”. I don’t see Pack Admin. But if I go to Admin → My Units → Pack etc… I have Den Admin and New Member Coordinator both listed. Help?

@NicolasDeArmendi - so you are just a den admin rather than pack admin from your positions page in scoutbook.scouting.org

Den admins are supposed to have access to edit the den calendar. This was recently reported as a bug.

Just to double check, is your den admin position assigned to a den?

I’m not a Den Admin. I’m a Pack Admin. I’m also the New Member Coordinator, which is the only position showing up in the dropdown.

@NicolasDeArmendi

perhaps a screen shot of your positions in scoutbook

Apologies! I’m not sure what I was talking about with “den admin.” Here are my screenshots. One of the dropdown that only shows “New Member Coord” and the other with my current positions.
Screenshot 2024-05-20 164114

@NicolasDeArmendi - so your default position is new member co-ordinator which is not on the list for calendar access. The default position is noted by the person avitar to the right of the green check

@NicolasDeArmendi Try logging in at my.Scouting.org. Then:

  1. Click on “BSA Web Links”
  2. Click on “Internet Advancement 2.0”

Also try a hard refresh by clicking on CTRL+F5.

So how do we go about changing the default position?

@NicolasDeArmendi - go to your position list in scoutbook.scouting.org then click on the pack admin line then there should be a slider for default postion. Make sure it is red, then on the new member coordinator turn that one off.

I can turn off New Member Coord, but there’s no slider avail under Pack Admin. I’m also getting a red key image. I’m thinking that must mean something!