Parent can't invite scout to scoutbook

We have a few scouts in our troop whose parents cannot invite them to Scoutbook. When the parent logs in and selects the scout, the “Edit Profile” button takes them straight to Internet Advancement. They never get the page with the “Invite scout” option at the bottom. We tried the workarounds here: Parent Can't Invite Scout to Scoutbook - Scoutbook Knowledge Base with no success. Any ideas?

1 Like

We are seeing exactly the same issue. I see some updated info at

But not sure if this works.

Setting up an Account Your Scout Can Use

If you wish to have your child have the scout’s own account you log in and click on their advancement record. Then the parent should login to, click on their Scout, then Edit Extended Information. At the bottom of the page there is the link to add the Scout. The Parent enters the Scout’s email address and invite’s the Scout. The Scout gets an email with account info. The Scout accepts the invite and can now log in. Scouts who have done this will show up on the Messaging list.
Here are the steps:

  1. Log into your own account on
  2. Open ‘My Dashboard.’
  3. Click the ‘Child’ under My Family
  4. Click on your child’s ‘Edit Extended Information.’
  5. Go to the bottom and click ‘Invite xxx to Connect.’
  6. Enter your child’s email address
  7. Have your Scout log into their email account and ‘accept’ your invitation and choose a password.

The developers are working on restoring the invite scout to connect button

Thanks for the update!

Parents can go to and do this
Myst Account Setup.pdf (223.2 KB)

Then the Scout can use those credentials to log into Scoutbook

I do know the Scout must be 13 years of age. I tried to add my son and he won be 13 until January.

Not sure if that is helpful or not.

This hasn’t been enforced in the past. It may appear that is the reason, but the main button interface is broken.

They take some steps to ensure that the parent is creating it on their behalf, but it doesn’t strictly prohibit it.

1 Like

Do we know when this will be restored? We are still having trouble with this feature. Thank you so much for your updates.

I’m not sure. Hopefully…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.