Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.

Scouting Forums

Recording a new Activity (Service Hours)

Hi. I am our Troops Advancement Chair. I am trying to input Service Hours. I can put in all requisite details. However for some reason when I get to Project Details, neither the Category or the Collaborative Org pull down boxes work for me. I can’t access them therefore I can’t complete adding service hours. The Project Description box allows me to put in text but I can’t pull down the Category or the Collaborative Org boxes. Thus I can’t complete adding the activity. Any ideas? Thanks.


I am having the same issue. Following.

I am having the same issues with SCOUTbook.

You may wish to follow this discussion here: Trying to add Service Project in IA

There definitely seems to be an issue at the moment and I have alerted the developers. Trying to find a commonality between browser and OS in case there is a relationship to these.

I have tried on my laptop and a desktop and my son’s college laptop using both Chrome, Firefox and on my phone using safari - its NOT working at all. I’m more than a little frustrated with IA lately.

Please let the developers know they NEED to test updates before putting them out to the masses.

I was able to use my phone on 10/10 to input service for my units. I tried Saturday 10/24 to input and the fields were greyed out on my phone. Checked my desktop today and same issue.

This is a known issue. The developers have been notified.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.