Roster has disappeared from IA

When I click on “activity logs” from scoutbook, it takes me to the Internet Advancement page where I get a message “Unable to find the person for the given GUID.” That’s in a pop-up box which fades out after a while. The page underneath has a message that says “The person was not found within the active unit.” This occurs for any scout I try. When I try to click “Edit Profile” for anyone within scoutbook, I get the same message. And when I try to “add person” to an event in IA, the drop down menu says “No Data” instead of listing the scouts and adults in our troop. All worked normally a few weeks ago. Help!

@WilliamFrench Are you able to access Internet Advancement by going through my.scouting?

Yes. I can access it either through scoutbook or through my.scouting. It doesn’t show any of our people either way. I CAN run reports of past activity, which show all the right names. But I can’t edit them to add anyone new.

I can see my own profile in IA, and the profiles for my two sons in the troop. I can’t see anyone else’s profiles. None of us, including me and my own two kids, show up in the drop-down menu for adding participants to events.

@WilliamFrench - in IA in the upper right do you see something similar:

Screenshot 2023-07-26 190530

Click on the unit dropdown

Yes. I am offered 3 choices in the dropdown. Choice one is Scouts BSA Troop 86 BOYS Position Scoutmaster. The two other choices are Parent/Guardian, one option for each of my sons in the troop.


Did you earn Eagle in 1985? I believe I may have found a 2nd Scoutbook account for you but it does not have a DOB or e-mail address so I can’t match it up with your existing account.

Yes, I did earn Eagle in 1985

I merged the Scoutbook accounts. You would not have been able to log in to the 2nd account because the MID was previously merged when Councils had that ability.

I don’t see anything wrong with your account that should prevent IA from not working properly.

Thanks for merging the accounts, I guess, but that has not solved the problem. I have been the scoutmaster for a year or so, and an assistant for several years before that. This problem is new within the past few weeks. The existence of an old account from when I was a scout myself has never caused problems before. Whatever you did to merge the accounts has not fixed it. I still can’t see or access any members of my troop in IA,

I have asked the developers to investigate as I see nothing wrong in my view of the database.

I have not checked with all the other ASMs, but the one I did ask had the same problem. She could create a new event (for our summer camp this year), but could not see any scouts in the drop down, so could not add any attendees.


Can you access your Scouts in Scoutbook?

I can access my scouts in scoutbook. I can update their advancement. But I cannot edit their profiles. Attempting to edit profiles kicks me over to IA, where it tells me they are not in the unit.

Thanks. This will help the developers.

Thanks for your help. I asked a person at our local Council about this too, but she did not know how to fix it.

Is there any progress towards a solution on this? It’s going to rapidly become a headache if I have to track all service hours and camping manually. I need to input what everybody has done over the summer.