Scout Cannot start merit badge

A scout is trying to start a merit badge, but when he clicks the start a merit badge button he is redirected back to the My Account Page

BSA ID 132679530
User ID 4631932

Thank you in advance for your assistance.

sounds like the scout has a pack membership also in Scoutbook - if so put an end date on Pack membership

@BenjaminWard you are wrong - Scouts can easily Start a merit badge - that follows the GTA

the problem is you are editing - “ - A few merit badges have certain restrictions, but otherwise any registered Scout, or qualified Venturer or Sea Scout, may work on any of them at any time. Before beginning to work with a merit badge counselor…” - MB work does not have to happen with an MBC - it can all be done before an MBC is assigned - it is a risk as the MBC does not have to accept the work

Donovan, Checked that already. Had that issue with some crossovers earlier. In this case only a single membership is active.


Did you look on advancement page to make sure it was not already started? what is the Scouts BSA #

@DonovanMcNeil in my experience if a merit badge is started it doesn’t even show up in the search list. However I have asked the scout for the merit badge he is trying to start.

Bsa ID and user ID below.

BSA ID 132679530
User ID 4631932

Have the same issue with my son.

BSA ID: 131877352
User ID: 7286937

@AhmedZaidi Which merit badge are you having difficulty starting?

So I tried with a private browser (and my sons login) and it worked. He was trying to start I Game Deaign I believe.



According to our view of the Scoutbook DB, your son has already earned the Game Design MB. This is why you do not see it in the list of new MBs to add.


So I opened up a private browser and he was able to start the merit badges. He earned them at summer camp and we needed to enter them in scoutbook.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.