Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Can Not Start New Merit Badge

When I try to start a new merit badge, I get sent back to the main dashboard window.
I go to My Account  My Advancement  Start Another Merit Badge (+ Symbol)
When I click on the + symbol, we get kicked back to the main Scoutbook menu.

I am not sure if this is related or not, but my Scoutbook profile defaults to my Cub Scout history, rather than my current Boy Scout profile. I have to go into my memberships, and change to the Scouts BSA membership to see my current Scouting profile.

Check to see if you have a current pack membership listed under your My Memberships. If so, ask one of your troop Scoutbook admins or a parent to put an end date on the membership.

You should also ask your scoutmaster to check whether your official registration is showing up in member manager.

That looks like it may have resolved the issue. I have 3 different memberships listed for Webelos for some reason! Thank you!

Glad we could help. It’s not entirely uncommon to end up with extra memberships for some reason.

Unfortunately it looks like it only fixed half of the problem.

My Scoutbook page goes to the Boy Scouts profile now. I tried to start a merit badge, and was able to get the full MB list. I logged out of Scoutbook.

I logged back in to Scoutbook 5 minutes later. When I tried to start a MB, I get the beach ball spinner, and get kicked back to the Scoutbook main menu.

Talk to unit admin and make sure your membership and any positions are approved

We discovered that the parents’ account can start a new merit badge, but the Scout account can not start a merit badge. The Scout can get into the merit badge activity once we add it from the parent account.

still something with his Account - I just started one in a Scout account - but I am glad you have a solution

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.