Scoutbook APP does NOT allow users to login

This is Completely Unacceptable. There was an update on 3/21/22, and since then I (And MANY leaders in our pack have been unable to log on to the Scouting app with the Red icon.

While I’m on it, the Scoutbook Website still defaults to MOBILE instead of a Desktop version even when on a Desktop computer. Tried 4 different browsers, 3 different desktop computers and it ALWAYS goes to a Mobile page. (Second is a Continuation fo a previously Started topic in which got closed with no ACTUAL Solution.) “Just use Mobile” is not a solution.

There has never been anything But the Mobile URL - it is just how it was named - on the app I will have to check later.


@TheSteaks - and i would note that the scouting app us for parents and scouts and not for leader access.

I was able to log into the scouting app without issue.

1 Like

Then from a Developer standpoint the /mobile needs to be removed from the Address Bar It can cause some other browser issues with the Browser trying to redirect to a Desktop site instead of a mobile site.

The Scouting App (Scoutbook) is for All of the above. Scouts to see what they need to do next, Parents to see how their scout is doing, and Leaders to record and track their scouts from an organizational standpoint.

Prior to the update, I was able to put in advancements for my child as the den leader, but there was no way to connect the rest of the den. It took going all the way to Council levels to get the Dens figured out and corrected. This would have allowed full access to all scouts in the Den from the Scouting app (Scoutbook) to put in their advancements and awards.

The Scouting App has always only supported Scouts and Parents. Leaders have always needed to log in to Scoutbook to manage their Scouts.


Scoutbook has used /mobile since its inception years ago without issue other than confusing users. There are no plans to change the UTL to remove /mobile.


@TheSteaks - just to be perfectly clear on this. The Scouting app in the play store apple app store is for parents and scout and was never ever ever designed for leaders. The URL is for the unit leadership, parents and scouts. I really do not understand how you or anyone else in your unit would have used the scouting app for den leaders.

1 Like

Are you saying that you can successfully log into, but when you try to log into the red app with the same username and PW, it won’t even log you in?

Yes. That is Exactly what I’m saying.

We could show Advancement requirements, progress and sign off things done by the scouts in the den within the app. I only could see my scout, but other den leaders could see all in their den and do even more than scoutbook website allows… i.e. Service Hours, Hikes, Conservation Projects, etc…

@TheSteaks Does it give you an error message?

Just says Loading with the campfire for 10m before I gave up. Never got an error. Cell Service and Wifi were Great as well… so its not a " My service sucks" issue.

On an iPhone or Android?


Delete the app and reinstall it. It sounds like you had an old version installed that is conflicting with the backend servers.

Android. I also have 2 iPads, but haven’t tried there yet.

I uninstalled it already 2 times and reinstalled before starting this topic. The second time, I even cycled the Power of the phone for 5m off then back on to clear all “latent data”

I just did a fresh install of the scouting app on my android tablet and was able to login without issue. I also have no issues on the phone which has had the app installed for a while now.

1 Like

Do you happen to use Apple or Google login?


Your account is setup for Google Login. Are you using the Google Login button on the app?