Scoutbook touch and go

I have been using scout book for a number of years. The last couple months have been the worst experience I have had with this program. As the advancement chair I use the program a lot. The calendar option used to work great now I have to fight with the program to get an event created. Sometimes I have to put it in twice and cross my fingers and maybe it will work. I have been having this issue since they tried to roll out the new update then rolled it back to it current state. It seems like every Monday (Troop meetings) when I need scout book to work it just fails hangs or simple doesn’t allow me to sign in. Completing merit badges or even getting to the roster the program hangs. I have tried with the following browsers Edge, Chrome and Fire fox.

Is there an ETA for the problems I have listed? The program/website is simply unusable/unstable.

BSA IT is aware of the issues tonight and is investigating. At this time there is no ETA to restore service.

Our troop has had the same issues as the commenter on this thread. Every Monday night ScoutBook slows to a crawl or is unavailable, making it frustrating and difficult to keep up advancement records in a 60 Scout troop.

@edavignon it looks like the system is having issues again. Saw a facebook comment and tried it myself, no access.


I have not seen any reports on FB today and am not seeing any issues with Scoutbook.

What problem are you having?

Not sure if this is directly related, but Scoutbook didn’t work at all for me Monday night when I was trying to do entry after our PLC meeting. Scoutbook is now back up for advancements, but I still cannot get Internet Advancement to allow me to enter a new activity or edit an existing activity. I’ve got 40 people from last weekends campout to log. I get this error " You have encountered a problem with this feature. Please clear your cache and try again. If this does not resolve your issue, please contact your council." I’ve cleared the cache, no luck.

I was able to take one of my sons who was on the trip and submit the activity as his parent, but when I go back as the Scoutmaster to update the activity to include the 39 other scouts and adults, it just produces the above error. I’m stuck, how do I move forward. I’m not sure someone at Council will know what to do here.

Also I’m getting a prompt when I log in that my sons and myself have memberships that have expired on 12/31/23, but we complete recharter and our roster shows us all good through 12/31/24. I just keep clicking cancel on those pop ups and see there is a notice on SB about some issue with renewals. I’m not sure if this is related to the issue with logging activities.


Monday’s issue has been resolved.

Try a hard reset, for Chrome hold the shift key and click the browser refresh button.

As noted at the top of Scoutbook, ignore the message about membership expirations.

Thanks for the tip, but that didn’t work. I’ve tried an incognito window and even opened Microsoft Edge for the first time in forever. Same issue. Just trying again now with multiple refresh and shift refresh. I was able to get the pop up edit window to show for a second, but then it closes and I’m left with the error.

@JonathanPeterson2 Can you log in to my.Scouting and go to your troop Roster. Use the Position Manager to end your “Registration Inquiry” functional role. You will need to wait for an overnight sync process to run.

Then try accessing Internet Advancement using this path:

  1. Log in at my.Scouting.
  2. Click on “BSA Web Links”.
  3. Click on “Internet Advancement 2.0”.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.