Scoutbook Plus Bulk Entry not Working

Ok so I did some testing and I really think the bulk entry for adventure awarding is NOT working correctly. When selecting multiple scouts and updating / approving… it ONLY UPDATES THE FIRST SCOUT SELECTED. All the other look like it has processed, but when you look at a status update of the individual scout, it DOES NOT show up as approved in the system. And yes I tried the hard refresh. I was able to reproduce this 3 times with different scouts.

Also, when trying to bulk input adventure data and approve, I CANNOT approve my own child’s progress??? It errors every time I mark “approved”. When I uncheck it, then it works and let’s me process the bulk acceptance. So then now i have another step to go into legacy scoutbook, run the “needs approval” report and approve all of them there. I am den leader and cubmaster so there should not be a permission issue at all.

1 Like

This is a known issue that’s been raised with the developers, per multiple SUAC responses. Keep an eye on (or subscribe to) the Scoutbook Change log category here to get notice when it is fixed.

What den rank are the scouts in? What version of the rank is set as current?

I’m an ASM, so I’m more current with issues hitting troops, but I understand from watching the forums here that there are issues with some rank levels where, apparently, toggling the version between the current (2024) cub requirements and the previous version appears to clear something in the back end that’s interfering with advancement “taking” in the database. I’m not sure if this is what’s causing your trouble, but it’s apparently being investigated by the developers (again, per SUAC posts).

The other thing that might (but shouldn’t) be causing the issue is being assigned both the CM and DL roles. Presumably one is the official registered position and the other is assigned in Scoutbook, since neither CM nor SL can dual- register in the same unit. I’ve seen situations where conflicting levels of permissions have generated odd errors, even though the system should, I understand, be taking the “highest” permission level in determining access.

@JasonMroz if this is still happening it would be good to set up a screenshare so we can take a look at it

I’m observing similar issues, but it is possible that some things are functioning “somewhere”. I just did bulk entries for Webelos/AOL dens for 9 adventures.
For my daughter - I observed that I can’t view any advancement in IA. But when I go back to Scoutbook interface, I see the adventures she’s completed/marked as approved show up, but don’t show up in IA/scoutbook plus. However, this may be because the completed adventure is Cast Iron Chef, which previously existed. It also looks like even though I selected 2024 Cast Iron Chef requirements that the system reverted to 2016 requirements.

For Webelos Paddle Onward (the other adventure they completed), only the first scout in the list shows it as completed. The 3 other Webelos scouts (including my daughter and two scouts that are not my children), the bulk add only went through for the first scout selected on the list.

Also on AOL bulk adventure, all the Webelos den shows up as well which is annoying/frustrating.

Good evening Donovan. I can for sure do a screen snapshot guide in the next few days and try to send it to you. I have some good computer software I use on my work computer and can easily take a bunch of screenshots to demonstrate what was going on.

To respond to some of the other comments here:

  • the issues happened in AOL, Webelos, and Bears that I noticed.
  • I was confirmed on the 2024 items for each scout. We were doing a swim meetup so some of these are brand new and did not have “old” requirements even to select.
  • I waited a a while, tried the same thing a few times, and kept having the issue with only one scout being updated even though multiple were selected.

Thanks for the response and I am happy to help troubleshoot now because when the year starts up i could see it becoming a much bigger issue as more and more packs are trying to figure things out!

1 Like

@JasonMroz it is much better to let me set up a live screenshare so other data can be captured if needed. Photos do little good

I also attempted to do a number of bulk entries for Scouts that attended Day Camp, and only the 2024 required adventures worked properly. For all elective adventures, the bulk entry would report “complete”, but then each Scout’s entry would not show any progress on those adventures.

I ended up spending ~2 hours entering each Scout individually. That’s not sustainable.

1 Like

Same issue here… This is taking way too much time. I have 14 AOL scouts and Scoutbook Plus is only recording the bulk entry for the first scout in the list on elective adventures.

1 Like

I attempted to begin adding my Scouts Adventures from Summer Camp and just the first Scout actually shows up. I don’t have the time currently to put in20 Scouts different requirements they met at camp. Just doing the cycling the other day for a Pack event last weekend took me two hours to individually log. We have a campout this month where we would like to do a fireside award event. Any timeline on when this issue may be updated so Bulk entry is working?

As noted in this thread (https://discussions.scouting.org/t/quick-entry-is-not-working-right/432530/9), the BSA doesn’t provide advance notice/timelines for fixes.

I assume this is this not working. Did anyone find a solution? I went through the steps and everything appears to be working and it says “success” but nothing is saved.

Had the same issue with adding adventure completion from summer camp today.

Trying to do Quick Entry for two Scouts and adventures recorded sporadically (some requirements recorded for both Scouts, some adventures only recorded for the first Scout selected).

No reason this shouldn’t have worked. Neither Scout is my child, I have Pack Admin permissions, these were all new 2024 adventures (no previous version), Scouts were in proper den for adventure, I cleared cache right before doing this, etc.

@RyanTashma this is a known bug - watch Change Log for fix

2 Likes