Scouts BSA History Report PDF

On the Scoutbook Reports Menu, the Scouts BSA History Report will generate correctly, but the button to generate a PDF pops up a box headed Print PDF with the message “The information is unavailable. Try again or report this to the forums (100). ref: PD-20231006091133-335511-640786” (the numbers are different each time since it includes a time/date code). This has been happening for at least several days. It happens with Firefox, Microsoft Edge, and Google Chrome. I have tried this with several different Scouts and have the same problem. The Eagle Application report does work, and immediately generates a PDF, using the same IDs and names.

1 Like


I have reported this to the developers. The ref: code changes because it allows the developers to find the report generation in the logs for easier debug.


The developers believe this may be a cache issue. Please do a hard reload of the page by holding SHIFT and clicking the browser refresh button or try in an incognito window to start with a clear cache.

I assume the developers are not able to repeat the problem. I have tried clearing the cache, hard reloads, and private/incognito windows in Firefox, Edge, and Chrome. I get the same results each time.

As a software developer of 54 years, I would be glad to talk directly to the developers if they want to reach out directly to me (Removed by moderator)
Tom Stalnaker


I passed your message on and removed your contact information from your post after doing so.


The developers believe they have fixed the issue. Can you please try again and let us know if it works?

The problem appears to be fixed. Thank you.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.