Service Hour Reporting - cannot post tenths of an hour

I reported this issue back on the old legacy forum and the developers fixed it but now someone has gone and undone the fix.

Its common for Scouts and registered adults to work less than an full hour on service projects. Before today, I could enter their time in tenth’s of an hour (i.e., 0.5, 1.7, 3.4). However, when this morning I tried to post service hours for an Eagle project, IA2 forced me to either round up or round down to the nearest whole hour the amount of time that the Scouts worked. Specifically, it would not allow me to enter the “.” and a number after it.

Forcing units to round up service hours renders the report untrustworthy and send the message to Scouts that they don’t really have to meet the full service time requirement; rounding down cheats the Scout out of service hours they performed. All of those tenths of an hour add up over time.

Chuck Olson
Troop 463
Sandy Springs, GA

Screen Shot 2023-05-21 at 10.42.07 AM
Screen Shot 2023-05-21 at 10.43.15 AM

Seems fine to me @CharlesOlson - where exactly are you getting the fail on the Eagle Project itself?

Screen Shot 2023-05-21 at 10.45.41 AM

Eagle project took a decimal


I was entering two different service projects. It took a decimal when everyone had the same amount of time. When I had to enter time individually, it would not allow me to enter decimals.


@CharlesOlson works for me BUT I am starting with one that HAS a decimal

Screen Shot 2023-05-21 at 11.26.06 AM

OK I see the Bug @CharlesOlson

@CharlesOlson hack is to save in group as as X.01 - where X is real hour. Then the decimals will be there for individuals till it is fixed


Thanks - that’s a practical work around.


@DonovanMcNeil - technical question on this. How does an eagle service project get entered. I see the assisted on an eagle project but not a direct eagle project unless i am missing something.

Project is Top Right of a Life Scouts Page

@DonovanMcNeil - perfect thank you… i was looking at a current eagle’s record. I appreciate it.

At one point the plan was for it first to be the Eagle Proposal in an electronic form like Eagle App - then it could be marked approved and transition to this (I said I was not sure that was needed and am not sure where it lies now)

1 Like

It seems to be browser specific - What platform are you using @CharlesOlson

Latest version of Firefox.

Yep fails on FF - works on Chrome and Edge - so it is at least a clue - one of the odder things I have seen

@CharlesOlson - you may be able to use the dev tools in firefox to capture where this fails…just a thought. I would suggest a test project with capture on.

@CharlesOlson this is fixed for me now

@DonovanMcNeil - thank you, sir. Always a pleasure working with you.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.