System is not saving Merit Badge sign offs (there is no error message, system just doesn't save the entries)

Hello,
I am a MB counselor and I just went through a session with a scout where he accomplished sign-offs for a lot of the requirements, but when I enter them into Scoutbook and try to save, the form comes back blank. I have tried both Chrome and Firefox, and I tried multiple times to enter the requirements. The scout is currently registered, we are working with the correct version of the MB, and I am able to see him linked to me for this MB.

Has anyone else had this issue recently?
Thank you for your help.

What is the Scouts BSA #?

Hello,

The scout’s number is: 136544016

I’m not sure if this is a separate issue or related but:
I checked another MB that I recently did with a scout who is not in our troop. I did update his record with his requirements (Citizenship in Society) and they were there when I checked but now I see that his form is blank too. (I don’t have his BSA number–I believe his Scout Master set up his MB with me).

I have had this issue before with a different scouts as well, where the requirements didn’t show up on my screen. However at that time, our Advancement Chair could verify that the scout’s requirements were signed off and they looked checked off to her on her screen.

Thank you very much for trying to figure this out.

Interestingly, when I go to “Print Blue Cards” I can see the items that are checked off for both this scout and the other scout. It seems that it is just not showing up on the ‘quick entry’ screen.
Thank you.

@CatrionaLogan - perhaps some screen shots could help. But once entered you should be able to go back to the merit badge requirements and see if indeed they are marked approved by you.

Hello,

So poking around again, if I go to ‘Edit MBs for MB counselors’, I can see the requirements and they are saved. If I go to ‘Quick Entry for MB counselors’ however, I cannot see the previous entries and the form is blank. I am attaching screen shots below. Unfortunately, this is different from what I was seeing yesterday, where I could not access the ‘Edit MBs page’ at all, and the Quick Entry screen was blank.

Is the Quick Entry screen always supposed to be blank even if entries were added and I hit ‘save’?

In the ‘Edit MBs’ screen, it is showing that the entries were put in yesterday and approved today. What I did today was to re-enter the requirements under ‘Quick Entry’ in order to try it again (and hit save). This time it now it is appearing in the ‘Edit MBs’ screen.

As long as I can verify that the approvals are being saved, I’m OK with this, but I guess if someone could verify if the ‘Quick Entry for MB counselors’ should always be blank, or if this suggests a possible issue, I’d be grateful for your input. Thank you so much for your time and help.


@CatrionaLogan - the quick entry does indeed reset… no bug then at all. I would always recommend that you go into the MB itself to assure that the entries hit. But indeed the quick entry becomes a clean slate once you save

Because quick entry can be used to enter for multiple scouts at once, it could not reflect their status on each requirement.

1 Like

Oh! Ok. I’m sorry. I did not realize this.
Thank you for clarifying and I’ll remember this for the future.
Thank you to much for your help!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.