Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Training Manager

My.scouting won’t let me in to any of the training manager pages for any of the units I have access to. Anybody else experiencing this issue?

I’m not having any trouble (Unit Key 3 delegate) accessing Training Manager. Is it just not displaying at all (i.e. no landing page displaying the pie charts), or is it throwing an error when you try to view/update training information for a specific person.

This is what I get.

That’s really weird. I see it just fine from my.scouting.org/dashboard-legacy → Left Menu → Unit Number → Training Manager, and I get the dashboard showing the training pie charts. I’m using the current version of Firefox, regular browsing window.

Are you one of the unit Key 3 for all of the units, or a UC? Maybe it has to do with the role?

I assume you’ve already tried a private window, clearing cache, a different browser, all that usual jazz?

I am the COR for the unit.

Tried chrome and explorer and incognito window. All same results.

Have you tried running a browser debug window to see if it reports what the URL you’re being directed to is? Mine takes the form:

https://my.scouting.org/< alphanumeric string >/training-manager/dashboard

The only other thing I can think of is that you’re somehow no longer correctly shown as the COR, but I would expect that would be obvious from your profile page at my.scouting.

Anybody from SUAC or with insight into my.scouting have any thoughts?

Everything else is showing up fine in my profile and on the roster side of it. Just the training manager that is messed up. It flashes for just a second and then sends me to the 404 site.

1 Like

@JohnGeiser

You may just need to clear your cache. If you have not been consistently using Incognito mode, then you have built up a cache that will carry over when you are in Incognito mode.

Here are instructions for clearing cache on most browsers:
How to Clear Your Cache on Any Browser | PCMag

I just ran MyST, went to a unit, and opened Training Manager without issue. So that would be my first suggestion. If that doesn’t do the trick, let your Council support staff know of your issue, your MyST username and BSA ID number and they can submit a ticket to National.

Started working again this morning without doing anything, so I don’t know what happened.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.