BOY SCOUTS OF AMERICA

Scouting Forums

Training Modules lock up

Has anyone had issues using the My.Scouting training modules? I started one last night and it got about 3 minutes in and completely locked up in my browser. Every time I go back in to that course it is locked up at the same point in time. I can’t restart; I can’t continue. This has now happened on several of the modules. I’ve tried using Chrome, but I get the “Page blocked by extension” error and I have no extensions enabled. Anyone experience issues like this and know how to get past them?

OK - I sent an email to BSA IT to try to get this looked at - trying to track down the correct contact - will update - in the mean time try clearing cache, or Private Window, or different browser - Good Luck

I tried clearing cache.
I’ve tried 4 different browsers.

Chrome: Requests to the server have been blocked by an extension. (I have no extensions enabled)
Firefox: Spins on Loading Scripts indefinitely. Doesn’t even make it to the Dashboard.
Microsoft Edge: Doesn’t make it to the training page even though pop ups were enabled
Internet Explorer: The only browser that actually starts up the modules, but is locked up in the middle.

I suspect when you get to the end of a BSA Learn Center online course the learn center server has to connect to a different server or spawn a different program to record the completion of the course. That may be where the process is hanging.

Of course, the “hang” may be caused by something else.

@ChristopherSnyder,

Try in a Chrome incognito window. Chrome blocks all extensions when using an incognito window. There may be something running in your normal chrome window that you don’t realize is there.

Which training module are you trying to run?

Are you using a work computer or home?

I’ve tried on 2 different laptops at home and am currently trying at work on a desktop. All with the same result.

Scouts BSA - Troop Committee - Before the First Meeting -> Scouting Organization for Scouts BSA. It locks up on the Patrol -> Patrol Leaders screen. Every time I go back in it is locked up at that same point.

Christopher,
Thank you! The programmers are looking into it.

@ChristopherSnyder I have run that Patrol Module on 2 different computers and 2 different my.scouting accounts no issue - are you going top to bottom down the list on selecting the different sections?