Hazardous Weather Training Module stuck

I have completed the Hazardous Weather online Training Module, but the training module will not move forward with a Continue button. I am stuck at 80% with 1 topic left to go, but I can’t move forward. I have cleared my cache and taken the course a 2nd time with the same issue. don’t know what to do next.

Howard - where specifically in the module are you stuck? What Browser are you using? Have you tried using a private browsing window (Incognito in Chrome, or InPrivate window in Edge)? What operating system are you using?


I have a leader hitting this issue as well


I’ve been trying for several days to complete the Hazardous Weather Training module. The module keeps getting stuck on an blank screen after completing the Hot Weather and the Tornadoes sections. I tried skipping these sections and saving them for last, but the module keeps freezing up. I tried logging out & back in as well as unenrolling from the course with the same results.

I am working on a Mac. Thank you for your assistance!

The first thing to try is clearing your cache. If that doesn’t work try downloading the chrome browser and doing it in there. Let me know if that fixes it

I cleared my cache and also tried completing the training on Chrome without success. When I unenroll and then start the module again, it still shows my progress at 40%, regardless of where it got stuck previously. The last time I attempted it, the slide format would not allow me to select an answer…
Thank you for your assistance!



1 Like

If they are using Chrome, have them select an Incognito window. I have been recommending this to anyone using My.Scouting for years.

It is too bad that it (incognito) needs to be done so often with BSA websites. I don’t know if other software, public or corporate, that requires this. Yes, I have done it for troubleshooting from time to time, but when it becomes “standard”, it shows something is up with the programming approach. So previous sessions leave so much behind that they need a clean slate each time?


I have not gotten to the final “Continue” button in 3 tries. I changed to Edge browser from Chrome, but no difference. I have tried Chrome on Windows 10- all updates confirmed in “In Cognito mode”- no change. At this point having sat through the course 3x with Noone at BSA tech support to contact, I am not going to spend any more time on this. Amazingly frustrating for such a simple online course.

Howard D Goldstein
Scoutmaster Troop 815 Danville, CA
howard@goldsteinworld.org | 925-876-0999 | https://www.linkedin.com/in/howieg/


Howard -

We try to do the best we can from here. Technically, first-line support is a function of your local Council.

Have you increased the text size in your browser? I know lots of folks who do, and it cuts off the bottom of the window where the button is located.

@TimothyRogers - can you check on Monday?

Addition: The Hail module won’t record that it was completed.

Howard D Goldstein
Scoumaster Troop 815 Danville CA
howard@goldsteinworld.org | 925-876-0999 | https://www.linkedin.com/in/howieg/

The Hail module won’t record completion even though I completed it 3 times.

Howard D Goldstein
Scoutmaster Troop 815 Danville CA
howard@goldsteinworld.org | 925-876-0999 | https://www.linkedin.com/in/howieg/

I did not increase the font size, but I did try to reduce it and no change in the CONTINUE button showing up. The “Hail” module still does not show completion even though I have successfully answered all the questions and it puts me back at the MENU.

@RonaldBlaisdell ;@timothyrogers;
This problem is not a local Council problem, it is a problem where the software is running online.

I will check back on Monday and have submitted a Jira request, but this problem should not exist for a module that is needed for so many ASMs in Training for WoodBadge, Scoutmaster, ASM, etc.

1 Like

@HowardGoldstein you have been marked as complete in the system.

@RonFedele without specifics - who, council, BSA ID, etc. not much I can do!

My name is Howard Goldstein, GGAC, Troop 815 Danville CA, BSA ID: 13008556.

Howard D Goldstein
Scoutmaster Troop 815, Danville CA
howard@goldsteinworld.org | 925-876-0999 | https://www.linkedin.com/in/howieg/


Howard D Goldstein
howard@goldsteinworld.org | 925-876-0999 | https://www.linkedin.com/in/howieg/

I’m ‘glad’ we aren’t the only ones with this problem - my pack has a leader who has been trying to complete this for 2 weeks. She is stuck on tornado. Our council said that National says there isn’t a problem with the online training system. But can’t figure out how to get her to get her computer to advance thru this module. So she is in training limbo until it gets resolved.

Perhaps this is at play

A new update came out for hazardous weather on Monday log out clear cache and try again

I had the same issue on the tornado section and found that you have to check all answers even the wrong one. It fixed the issue and completed the training

1 Like

I too have had the same issue on this training module. I have used various browsers and settings to no avail.