Trouble Entering Adventures and Running Reports

We’ve started our Summertime Fun and I’m entering events as we have them. I’ve entered for all our scouts but I’m running into a problem with an AOL, my own child. I get an error message of “User cannot approve requirement.” I am the den leader for the AOL Den as well as a Key Three, so I’m not sure why I can’t approve the requirement.

In the old SB we had an option to run a report of items that had been recorded as complete but not approved and you could mass approve them all or approve individually. I haven’t been able to find that in SBP. I played around with it and I marked one of my den members as complete for a requirement, but not approved, to see if I could find a report option to view items that need approval, however I still couldn’t find it. Is that an option on the new SBP? Sometimes Den Leaders forget to check “Mark as Approved/Recorded” when they enter advancements, and that report was helpful so I didn’t have to go to each individual scout’s record to see what needs approval.


There is a known issue where leaders cannot approve advancement for their own children. The developers are aware and working on a fix. An announcement will be posted in the change log forum when this is fixed.

Try removing your Scout then approving again then have another leader approve for your Scout.

1 Like

Thank you! I unchecked the “Approve/Record” and it saved it. I’ll have the CC approve it for me. I appreciate your help!

I was able to approve the Knife Safety elective he did this past weekend.

I will look for the change log forum to keep an eye on an update.

Is there a way to run a report to see what needs to be approved? Or do we have to go into each individual scout’s record to see if things need approval?

the Needs Approval Report is still live in SB and in SB+ there is the Pending Items Tab on the roster page

Ok, thank you. I checked the Pending Items Tab when I was playing around with it and the requirement I only marked as recorded and not approved didn’t show up, but I didn’t hit ‘refresh’ on my page, which I’m finding I need to do for things to show up. I bet that’s why. I’ll keep playing with it and test it out. Thanks so much for the quick reply. Is there a known date of when SB will be officially done?

BSA does not release info like that

Ok, thank you.

I just marked part of an adventure as recoreded but not approved. I have refreshed my page and it is still not showing up under Pending Items. It is however showing up as needing approval in old SB with I run a Need Approval Report. Any other suggestions on how I can fix that?

SB+ has cache issues that can be slow

Sorry to bother you again. It’s been a day and the adventures I marked off but didn’t approve are still not showing up in Pending Items. Thinking it was a problem with my account I asked our CC to check and they do not appear for her either. I can see Pending Items for my older son’s Troop that I am a volunteer for as well, but not a Key Three for them, so I am able to see Pending Items. They’re just not showing up for my Pack. I can see them through the old SB Needs Approval Report, but was hoping I could use just one platform, but I may be getting ahead of myself! Thanks so much for all your help!

@PamelaNelson1 can you try an incognito or private window for us?

All attempts I’ve made have been in an incognito window because regular browser windows have been giving me an issue with login.

Still no Pending Items in SB+ in an incognito or normal window. Any other suggestions? I don’t mind using old SB to run the Needs Approval Report, but if this is a bug, can I/we report it anywhere? Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.