Try to add connection, ScoutBook won't find person by email or name. Does find them if I add them

Situation: Scout has connection to one parent. Other parent wants to RSVP and can’t.

When I try to add a connection for someone by their name or email address, I get this:

There’s nobody on the search screen.

But if I try to add them, I get this:

This is the case for multiple Scouts, meaning it’s not limited to this particular Scout and their situation.

I can reference the Scout’s SB User ID but I don’t see any way of doing that for parents who are not leaders.

SB User ID 12344091
SB User ID 12094994

1 Like

Is this a known issue with Scoutbook?

I know there have been issues with non-“Unit Admins” searching for MBCs due to changes made as a result of a data security concern of some sort. I’m not clear if that same issue extends to making other types of scout connections.

Maybe someone from SUAC can comment on that? I can’t easily test it because I’m a unit admin. When I search by name I get a return (with only name and BSA ID displayed, which is not ideal for most parents since it’s hard to easily determine someone else’s BSA ID). I also had success searching based on email address, which might make it easier for most folks to verify that they have the right person. Again, all it displays in the return is name and BSA ID.

Same issue here. I am pasting a picture for a search for Smith, but I have tried with many of the names of our troop leaders and the only way I can get this search to work is with an email address. [This is on the invite counselor screen]

Two Scouts, girl connected to dad, boy connected to mom.

Mom’s name fairly unique, Dad’s name pretty common.

On boy:
try to attach Dad using Dad’s email: no matches
try to attach Dad using Dad’s name: lots of results but as Charley says, impossible to tell which is the right one

On girl:
try to attach Mom using Mom’s email: no matches
try to attach Mom using Mom’s name: no matches

Neither Mom nor Dad is a leader.

Out of curiosity:

On girl:
try to attach girl using my email: no matches
try to attach girl using my name: 1 match (me)

On boy:
try to attach boy using my email: no matches
try to attach boy using my name: 1 match (me)

I am having the same issue with one of our scouts - search mom’s name, nothing comes up. Search mom’s email, the boy’s account comes up. Try and create a new account for the mom, am told someone with the same first and last name already exists. How can this be fixed?

Any update on this issue? I am trying to connect a MBC to a scout by creating a new connection, and get the same ‘No Record Found’ error when searching for the counselor. Entering in the MBCs email address doesn’t work either.

All we have been told is that it is in the backlog.

Thank you. Do you have a suggestion for an alternate way to complete the connection for the MBC?

Is the MBC already connected to one of the other scouts in your unit (or has an existing connection to this scout)? If so, you might be able to use Connection Manager (if you’re a Unit Admin) to make the connection to this scout, then go to the scout’s connections interface and add the MBC connection type. Just don’t set the “initial” connection as a parent/guardian-type since you can’t remove that.

I’m also having trouble connecting a MBC to a Scout. I’m Troop Admin for the unit. No matter what I type in the search it comes back with the “No record found…” box – I’ve tried both name and email address for multiple counselors. In this attached screenshot I’m showing the MBC list alongside the Add Connection window (with info blocked out to protect the innocent) – I’ve both retyped and copied/pasted the email address and/or name from one window to the other and it’s telling me it can’t find the MBC. I’ve done this in both Firefox 103.0.2 (for mac) and Chrome 104.0.5112.101 (for mac).

1 Like

It seems like connection search is borked for most of us at the moment.

Does the workaround I suggested above (via Connection Manager) work for you? Someone else posted it in another thread I can’t find just now, and it seemed to resolve the issue for them.

The Connection Manager trick does not work in this case. The MBC in question has been linked to other Scouts in the unit, but only as a MBC and not other type of Adult Leader (or Parent). Those types of connections don’t show up in the Connection Manager.

1 Like

I wonder if you can go to a scout to whom they’re already connected as a MBC, give the MBC View Advancement permissions, then use that to back-door in through the Connections Manager. After the original target scout is connected to the MBC with something like View Advancement, you should be able to add the MBC role, then remove View Advancement connections from both scouts.

A workaround would be for the MBC to add the connection with the scout’s last name and member number.

1 Like

I mean, sure. If you want to use a pathway that doesn’t require jumping through a million hoops. :rofl:


Now I can’t find myself or “John Smith” when I search.

So instead of things sometimes working, now they never work.

Same issue. I am troop admin and I cannot find anyone when I search. Doesn’t matter if it is by name or BSA ID number, it comes back with “No record found”.


This is a known issue. The developers are aware and working on a fix. We do not have an ETA for a fix to be released.


I’m having the same issue. This appears to have been the case since at least circa July 2022. Before that, I could find the BSA member ID and complete this. I’m looking for a workaround - my adult leaders can’t be assigned to positions.