Unable to access Internet Advancement from anyting for my troop

Troop 140B of Longhorn Council is unable to access anything from Scoutbook that takes us to IA. The screen just gives us colored dots spinning around for hours and nothing ever happens. I need to update camping logs, but it won’t let me do it. I am the Scoutmaster, so I should hope I have the correct access to do this.

There have been a number of reports about this from time-to-time. The first error checking steps are:

  • Make sure you’re on a “supported” browser. Chrome and Firefox typically work. Edge sometimes works. Safari generally doesn’t work reliably.
  • Make sure you try from an incognito/private browsing window with any add-ons/extensions off.
  • Try a forced reload/refresh of the page. Sometimes, IA2 caches information on the local machine that becomes out of date and has to be updated.

@DavidRussell7 - browser cache might be it… it is working for me

@DavidRussell7 Try 2 things - A private window and/or a Hard Refresh (Hold SHIFT + Refresh page)

Cache is clear. Using Firefox in private mode. Still not working. Also just tried going straight to the url and logging in and got this error message

@DavidRussell7 try Shift + Refresh

That brings the page with the never ending dots spinning.

Can you try a different device?

Developers say it is leading to the wrong unit - it is being looked at

Exact same thing is happening to me. I have tried all the suggestions and none of them work.

@MelonniShields what is your BSA #

My scout no. is 107274446.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

@MelonniShields can you please try again