Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Cannot log into Internet Advancement

I’m having trouble getting into internet advancement. Prior to last Friday I was able to get on no problem. I’ve tried every way - through scoutbook by the IA button and by clicking on activities log buttons for individual scouts and by going to the IA address without going through Scoutbook. I either get a gray screen with 4 blue dots circling or sometimes I get a login page, but the recaptcha expires and never logs me on. I’ve tried on multiple devices. Any idea what’s happening?

Lindsey,

What is your registered position with the unit?

Pack committee chair.

I should also mention that I CAN get onto my scouting.org.

I sent you a direct message. Check your Avatar in the upper right corner.

I’m having a similar issue.
When trying to record activities I can only see my family profiles.

As a Den leader and Cubmaster Key 3, I can’t see info for any one else in my Pack and therefore unable to log anything for anyone but my 3 sons.

I’ve discussed with other local Scouters who suggest something is amiss but don’t know how to correct it.

Any ideas?

so if you click the avatar at top right - in the drop down you only see your children? @RandyMisekow?

@RandyMisekow When you log in at my.scouting.org (my.Scouting Tools) are you able to access the Organization Security Manager for your pack? After you log in there, click on the Menu button in the upper left corner, then click on the link that has:

[your pack number] - [your district name]

if you cannot log into IA and you are a K3 - send an email to Scoutbook.support@scouting.org - Subject: Key 3 cannot log into Internet Advancement

Be sure to include all your information - : Unit, Council, District, your position

And your BSA member number would also be helpful.

I am also having the same issue. I am the Committee chair as well and listed as a Key 3 on my.scouting

Jennifer,

Yes, I can access that screen. My name is listed as the cubmaster. Expiration date Jan31st, 2021.

Is there an instruction on what I should look for or confirm?

Thanks Rand

Donovan,

Yes, that is correct.

Ive tried accessing that page thru my son’s profile and thru the Pack’s profile on Scoutbook but only see my 3 children as an option.

I watched the video on how to make entries on this system and my Avatar drop-down box doesn’t include many of the items shown in the video.

Thanks

Rand

@RandyMisekow There is an access bug that they are working on, but it would be helpful if you could send an e-mail to Scoutbook.support@scouting.org with the subject:

Key 3 cannot log into Internet Advancement

Please include as much identifying information as you can:

  • Your name
  • BSA member number
  • Unit number
  • District name
  • Council name
  • Registered position or role in the unit (Cubmaster, for example)

Jennifer,

Thanks.

Will do.

Rand

if you send email - when you get auto-response with JIRA # (SSD-#######) - if you post it here we can quickly pass it on - might not speed up process as DEVs need the info to figure out WHAT is going on - thanks

@DonovanMcNeil, here’s the interesting thing with IA access, developers mentioned allowing more positions in to see the activities (ASMs, Troop admins, Den Admins, asst Cub masters, etc…). When they made the change, I went from access only for my son to being able to see the Troop (in the drop down) as I am a registered ASM. I cannot, however, see my Pack (and I am registered as an assistant cub master, and the Pack admin, not to mention Den Leader). It seems most of the people posting issues with IA are Cub Scout positions. Could this be a commonality? Just trying to help find a link for you SUAC guys and the Devs.

1 Like