Unable to create individual logs for Camping/Hiking/Service hours in Internet Advancement

I have the Troop Admin role in Scoutbook and Unit Advancement Chair on my profile in myscouting.org, however, I am unable to create individual enteries for scouts other than my own.

How can I get this corrected?

John Kramme
Troop 631B


Is there somewhere else to reach out to so I can get this fixed?


Click on the fleur-de-lis in the upper right corner of the IA window. Make sure you unit is selected. Let us know if that fixes the issue.

1 Like

When I click, there are three options.


The top one is the one I am using that isn’t working. For instance, on my parent options, I can create/add under that scout, but when Admin is selected, I can’t do anything even to my own scouts.

@JohnKramme - were you able to do this at some point ? And could you outline your steps?


I log into Scoutbook.scouting.org
click on Internet Advancement
Click on Troop Roster
Verify I am on the Troop Admin role
Select ANY scout in the troop
Click on Camping under Activity Logs (Hiking and Service Logs do the same thing)

There is no “Create or Join” button shown.

If I select one of my parent accounts
I can go select Camping (or Hiking, or Service) and it gives me the optin to “Create or Join”.

@JohnKramme - what if in the roster you select scout or scouts then in the gray bar above the list of names you click on record progress and see if that presents a selection for camping, service, etc.

it creates it as a troop activity instead of an individual.

@JohnKramme - if only one scout is on the event then it is individual. Are there no troop service, camping or hiking activities?

I believe the activity logs were designed for individuals to create individual logs for themselves (or their own children). If you are a Troop Admin, you can create individual logs for yourself and your children, but if you create logs for other individuals in your unit, then they are treated as group activities – even if it’s just for one person.

1 Like

@JohnKramme - what Jennifer states is correct. The scouts and or parents should be creating the individual activities which will then presented for approval. Why do for a scout what they should do for themselves.

part of it is because we have had several scouts transfer from other troops. However, their information in ScoutBook did not transfer, so we are having to manually enter the information in. It isn’t their fault the transfer didn’t work properly.

Plus this is all part of the “We have to use SB for advancement” regime going on. Transferring logs from one program into another. Also doesn’t fall under the scout’s responsibility…

If they had logs that didn’t transfer, it sounds like they have duplicates accounts. Would you like us to look into that? We’d need their member numbers (no names).

1 Like

here are a few:

Transferred from same troop nearby:

Transferred from a different troop:

Thank you

I did not find any evidence of duplicate accounts for any of those scouts or any deleted logs. It seems likely that the previous troops never entered anything in the logs.

The system hasn’t been robust. Until then, we are creating all unit entries. Once these are more robust, we will turn it over to the scouts (as it should be).


I would like to just be able to add campout activities for my own scout but when I try and open internet advancement either directly from my.scouting.org of from scoutbook, i am stuck with a spinning wheel. Any advice?


I had an issue trying to connect via a regular Firefox browser window, but got around it using a private browsing/incognito window. The usually means (for me) there’s something wonky in the cache somewhere. Try the private browsing/incognito window to see if the solves the issue.

Thanks Charley. I am using Chrome and did try the incognito screen as suggested. I have also tried using MS Edge but it is the same issue. Will try on the chromebook tonight (complete separate machine).


I have been trying to submit Scouts service hours and I’m receiving the following error on my desktop. I also tried the app and received the following error.

Any help is appreciated!
Thank you,