Unable to generate advancement report: organizationGuid is invalid

I’m attempting to generate the first-ever advancement report for our girls troop and I am unable to generate the report. I’m getting an error message that says: organizationGuid is invalid

Sean Yeomans
Troop Committee Chair | Troop 380

I don’t see anything obvious.

What path do you take to get to Internet Advancement 2.0? Do you log in at my.scouting, and then go through the “BSA Web Links” menu option?

Do you have similar issues with your other troop?

I’m able to produce an advancement report for our boy’s troop without any issues.

Because of the limbo created by the ongoing negotiations with the Methodist Church, our girl’s troop is chartered by Circle Ten Council. I’d guess that was causing the problem.

Any help at all? I’m still experiencing this problem.

@SeanYeomans I have asked the developers to take a look.

Any word from the developers? I am still unable to generate an advancement report for our Girl’s Troop.

Still nothing?

No word at all?

@SeanYeomans have you tried opening an incognito window?

It also seems like your COR works for Council maybe - as he is EO for Tons of units - but is just COR for your one Female troop

Try seeing if there are any issues in your troop or chartered organization’s Scoutbook details. This sounds like a Scoutbook issue, not a unit configuration issue.

I’ve tried in multiple browsers and in privacy mode with the same result.

Correct. As I provided above, our girls’ troop was chartered by the Council as a placeholder while all the negotiations with the Methodist Church are being worked through.

I’m having the same issue. “organizationGuid in invalid” I’ve tried on Safai, Chrome, Firefox and on Windows and Mac computers no joy. It’s for our first report as well.

@TrevorSmith5 You had a duplicate Scoutbook account. They have been merged.

1 Like

OK just heard “organizationGuid” for some units does not exist in all the databases it should - this is being investigated and fixed


FYI, I’m still having the issue. If it’s still being worked on, I’ll be patient. But if you thought it was fixed, just wanted to provide feedback that it is still not working for me.

@SeanYeomans I have asked the developers about your issue again.

By any chance, can you create a Purchase Order (PO) if you use Scoutbook? And if so, can you access the Advancement Report in Scoutbook?

Hi @JenniferOlinger ,

Thanks for that suggestion. That works! Yay!

Unfortunately, I don’t know if it’s a long-term answer for us. Our Boys Troop uses Troopmaster and we’re currently very invested in integration between Troopmaster and our website. We have been using Scoutbook for the Girls Troop but still don’t know if that is a long-term option for us due to the complications it creates with our troop website integration.

So it would still be good to be able to generate the report for our Girls Troop out of Advancement, but thanks to your suggestion we can do what we need for now in Scoutbook.


A fix in in the works but not ready yet. Jennifer’s workaround is to allow you to proceed until the fix is released.

1 Like

@SeanYeomans Could you please try again?