Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Recharter Error - Whoops! It looks like we were unable to generate your charter for signature

I am trying to complete the recharter process for our troop. Validation step shows that we are all good. But when I proceed to the payment screen, and I fill in the required information, then press the **“Pay and Post Renewal”, I receive this error message:

“Whoops! It looks like we were unable to generate your charter for signature. No payment has been taken. Please retry again.”

I tried credit card or e-check but give the same error. I tried different billing addresses or names, but same error. I even tried different countries and phone numbers, same error.

Any idea what’s going on?

Regards,
M.

I’d say try again tomorrow, and report back here. If it still doesn’t work, provide your bsa member number and the unit you are trying to recharter.

Hello,
I tried the again but no luck. Same error message at the exact same step. Another key-3 member tried with his own login and got the same error. I changed browsers, tried Mac vs. Windows, but same error.
My BSA ID is 133914459, and the unit is Troop 0013 in Horizon District under the Transatlantic Council.

Thanks,
M.

I have asked the developers to look into this. I do not know when they will have an answer.

Another unit in Horizon experienced the same issue. Hopefully we will have an answer from the developers soon.

Another Unit with the error message when trying to recharter.

User ID#13916453 received error message “Whoops! It looks like we were unable to generate your charter for signature. No payment has been taken. Please retry again.” She retried and got the same message. User is paying with a Credit Card.
T970B Error.pdf (3.3 MB)

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

The developers say this is fixed. Could you have them try again?

The member was able to get it to process last night! Thank you.

1 Like

This is still happening for us. See screenshot below.

@RyanFedon Could you provide the bsa member number of the person trying to submit it and the unit this is for?

I was finally able to resolve the issue by removing the offending email from the member’s profile and replacing it with a dummy one. I was then able to submit the recharter and once that was complete, I changed the member’s email back to the correct one. Not sure why, but it did not like that email address.

1 Like

@RyanFedon, in case nobody from SUAC has already reached out privately, were there any special characters in the email address? How long was it?

I’m not looking for the email address itself. I’m thinking that someone else might have a similar issue, and be able to identify it based on either the presence of special characters or email address length. Also, ideally, the developers can “fix” the underlying issue based on the information.

1 Like

@RyanFedon What is the BSA member number of the person with the e-mail address that is not accepted?

No, there were no special characters - it was 11 letters and 1 number (12 chars total) @gmail.com: like xxxxxxxxxxx#@gmail.com

The BSA number of the person in question is 129530515

Thanks. Odd that there wasn’t anything weird about the email. My email address is way more than 12 characters, so I guess I’ll watch out to see if length is an issue when my unit submits.

Strange because in my case I did not make any modifications to any member’s profiles and the issue fixed itself when I attempted to submit the charter once again back on Nov 25th.

Yeah - very strange. The CC tried it several times over the last week, I tried it last night at the troop meeting, and I also tried it on Firefox, Chrome, and Edge - all with the same result. He tried again this morning (as did I) and still had the problem. I then tried removing the offending email as I stated above, and it worked.