Unable to log in to Scoutbook

Our advancement chair was trying to log in so she could enter and approve requirements for a scout.
When entering her login information she kept getting a message stating that there was ‘no account for the email listed’. She was able to successfully log into my.scouting, but every time she tried using the same login information in Scoutbook she got the same error message. Any suggestions on how we can correct this?
Her SB user id is 748034 and her BSA id is 123624438.

@MichaelSoares that user does not use an email to login - they have a user name Nana####

That is what she tried using the first couple of times, but kept getting the error message. She then tried with her email and also got the error message.

If they can log in at my.scouting they can log in at Scoutbook. Are they using a saved password - it might be wrong for Scoutbook

@MichaelSoares - they can also navigate to scoutbook via my.scouting.org. Click on BSA Web Links, then Internet Advancement and there will be a link to scoutbook. But I do suspect that there is a cached password issue.

She was using a saved password when she first tried to log in. After she got the error message I told her to manually enter the password instead of using the saved one, which still got her the error message. She then went into my.scouting and changed her password, rebooted her laptop and tried logging in with the new password, to no avail.

I will have her give that a try and see what happens.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.