No Scoutbook Access

this has happened before, so hopefully it can be fixed again. One of my adult leaders can access my.scouting, but when she uses the same credentials for scoutbook, she receives an error that states, “We were not able to find a scoutbook profile linked to this email account. If you already have a my.scouting account please log in here”
her BSA ID is 12662744

Thank you!
Sara Warren Troop 931

Everything looks fine - they are logging into the Scoutbook “Scouting” app daily - are they trying to login to

Can you help me with my son’s login. I invited him to scoutbook years ago, but he does not have the login info now. When he tries to recover his login info, via BSA ID or email it says “No accounts were found matching the information provided. Please [contact your local council]” However if I go on my dashboard - he was already invited to scoutbook years ago, I tired sending him a message and it sends him a message to his email, but he cannot use it to login. Nothing I have tried has worked to recover his account. Which is there because it is on my dashboard. I was able to invite my other son last night no problem.
His BSA ID is132090134 mine is 132090135

@MeghanKramer yes he logged in 2021 - has he tried using the BOT to reset the password?

@MeghanKramer it is like a Signin User was not made so I am a little lost - you could also try going to - click on Left side to create a new account - enter the info and MAKE SURE it matches up to your Scout - otherwise stop - then you can use that to sign into Scoutbook

So I should create a new account for him, this somewhat terrifies me that it will delete all his info

Myst Account Setup.pdf (223.2 KB)

It cannot erase anything - follow these directions and you should be gold

It worked - Thank you very much.

Hello! I’m the user this thread is referring to. Yes I am logging in to I can still access everything through the Scouting app, but not the Scoutbook link.

@SusanHuman try a Private or Incognito Window as a test - you might have a pop up blocker or something causing issues

I’m not sure if you changed anything but I just refreshed my browser (not in private/incognito yet) and it allowed me to log in, so I think/hope I’m good to go now. Thank you!

I was previously getting the same error on multiple devices.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.