Unable to view certain ranks for a new scout

Good morning All!

I have a newly crossed over AoL scout that I can not view Star Rank or Life Rank for. I get an error that states:

"Whoops! We encountered an error trying to process your request.

Our webmaster has been notified and will fix it ASAP!"

It’s been like that for weeks. I can view all the other ranks, just not those two.

The scout’s number is 137233401

Thank you!

It looks like the Scout has a multiple registration with a pack and a troop at the same time. Her registration should have been transferred from the pack to the troop. Please contact your council and ask them to end the pack registration.

I knew that was the case over a month ago when I wasn’t able to assign merit badges to the scout. Since then, the scout has ended their pack membership on February 27th. As soon as that end date was placed there, it opened everything up for me to see except Life and Star Ranks.
So while I see that being the original issue, I fail to see it as the issue for this. It doesn’t make sense for me to view Scout, Tenderfoot, Second and First Class as well as Eagle, if that were the issue.

Could it be something else other than the pack membership that was ended on February 27th?

We have asked the developers to investigate the issue with not being able to open Star and Life rank.

1 Like

@CrystalWorsham Your Scout still has a registration issue that needs to be fixed. Please contact your council and ask them to end her pack registration.

Not being able to open the Star / Life rank requirements page in Scoutbook seems to be a separate issue.

@CrystalWorsham try something for me - start several MBs for the scout - you do not have to mark off any requirements - just start them - if you have the Feature Extension you can use the Quick Entry Start Merit badges. This solved it on the test server

@CrystalWorsham STARTING one Eagle required and one Elective MB solves the issue.

RE Crystal’s issue of not being able to open Star/Life. I just attempted to open Star/Life from both Advancement page and Star from 1st Class and Life from Eagle for several scouts in my Boy Troop: 4 are new crossover scouts from the pack (AOL only), 2 are Tenderfoots, 1 is Scout Rank, 1 has are joined in the past 9 months. None of the scouts have any merit badges. I do NOT remember having this issue in the past.
For one of my scouts with this problem I changed the Eagle Rank from 2022 to 2016 and had the same problem, then changed it back.
Do you need any of the BSA ID#'s?
Just starting a Merit Badge for each scout sounds like a work around that will allow all of us users to continue until it is resolved.
This appears to be a bug that should be reported to the developers.

@MichaelMcGehearty it is reported - I just happened upon the fix trying to figure it out - Developers are working on it.

Great! When fixed it will probably show up in change log and maybe on the thread.

I’m dealing with the same exact bug… can’t see Star or Life ranks (get an error message), both were previously working fine… all other ranks currently working fine… reported it 2 weeks ago and still no fix…


We were only able to duplicate the issue today and have reported it to the developers.

The developers have found and fixed the problem. The fix is being tested and will be released soon.

The workaround is to start an Eagle Required and Elective MB for the Scout.

1 Like

Can you please remove the Camping MB that was added so I can see if it’s fixed or if just the workaround is making it work? Also, the Scout doesn’t want that MB added to his account yet as he’s not yet working on it. Thanks! Also, when the account was worked in to try to do the Star/Life fix, two things were accidentally removed- the activity logs and the reports… both of those were previously working fine and now we can’t see them.

The fix has not been released. It is currently being tested and will be released once testing is complete. Watch the change log forum for an announcement.

Any MB can be removed by clicking on percent complete then clicking Remove Badge.

Ok I’ll be watching for the fix. I like knowing we have the workaround as an option though in the meantime. Thank you for the info and for your help, it’s much appreciated!

Thank you so much for your suggestion. I apologize for not responding earlier as I have been MIA on Scoutbook since Friday.

Yes, your work around did open Star and Life for my scout, but when I removed the items, I got the error again. Just wanting to give you that update.

Thank you for letting us know that it has been reported and I look forward to the developers fix on this situation.

Thank you for taking your time in helping us with this error!

@CrystalWorsham you do not have award/Complete/approve the MBs just start them marking nothing off

I didn’t do anything but assigned the scout, confirmed that temporary fix worked, then unassigned the merit badges since they weren’t officially started by the scout. I am not currently needing to enter anything for the scout in these 2 ranks, so it isn’t time sensitive. I was just curious as to why I couldn’t see the ranks. I am OK with waiting on the bug being fixed. I hope that is making sense.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.