Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Issue with Scoutbook

Hi All,

Several scouts in the troop are unable to make updates to their rank advancements.

Attached is a screen shot which shows the scout is trying to go into their Life Rank and make updates to their requirements and the see this message.

Whats interesting is this happens to a select few scouts and not all of them…???

The error message says; Whoops! We encountered an Error trying to process your requests.

Our Webmaster has been notified and will fix it ASAP!

What even more strange is that they can open their First Class, Second Class Rank requirements but see this error for Star and Life Ranks…?

Can someone please fix this ‘BUG’ so that we can complete the SMC and BORs for our scouts, we had to cancel these today.

Kr,/Navaid
Scout Master
Troop 2060
14th Nov.

@NavaidKhan If you could post some of their BSA member numbers, we can take a look.

Can you also check their current membership and see if they have more than 1?

It’s very strange as they can double click into their rank advancements for Second class, First class, but can’t for Star and Life. They were supposed to have rank advancement for Life today and we had to postpone it.

Now as I said earlier, there are some scouts who do not have this problem at all. And of all these scouts listed below didn’t have this problem before a few days ago.

Uzair Khan:BSA ID: 134758783
Zayn Khan: BSA ID: 134758802
Ryan Habib: BSA ID: 133942151
Sami Khan: BSA ID: 134443903

I’m collecting the same info for the other scouts. Please can you help solve this problem…!

Thank you in advance,
/Navaid

I was checking the membership question re. Uzair…?

He’s been in the same troop since 2017 but could these entries be causing the problem…?

I thought you add a scout to a patrol etc…?

I tried to change the memberships down but that didn’t make any change. Still they receive the same error.

That shouldn’t be a problem. I would normally expect the scouts to be in a patrol, but I don’t think that changes anything functionally for Scouts BSA (Cub scouts is a different story).

Now I’m seeing this issue?

Scoutbook is too ‘buggy’ what’s wrong with it?

Can someone explain to me how the scouts can do their SMC/BORs without the ability to update their requirements…?

I’m really hopeful you help get this resolved.

Go into the scout’s current membership, uncheck the position approved box, and click update. Go back in, check the position approved box, and click update.

If that doesn’t work, a key 3 member will need to check your official roster on member manager in my.scouting.org for the scouts. Make sure their bsa member number, name spelling, and birthdate matches exactly.

I really don’t know what to do?

I don’t see a way to uncheck his current position other than to reassign him, when I do that this is what happens. And again no difference, same error…!

How come out of nowhere this ‘bug’ appears…? I feel like we are trying to do trial and error and shooting in the dark.

I’m sorry I’m just frustrated with Scoutbook…:frowning:

Zayn Khan membership screen|690x226

Click the red “Scout’s BSA”. Then, do as I said.

Hi Jacob,

Thanks for replying back.

I can’t see the uncheck approved position box? I’ve attached two screen shots showing what I see and I click into the ‘red’ Scouts BSA and don’t see it.

I may be looking in the wrong place and perhaps have to call in the local Scouts office.

Kr,
/Navaid

@NavaidKhan You should see the Position Approved checkbox if you are a Troop Admin. If you don’t see it, then that sounds like you need to reset your Scoutmaster and Troop Admin roles in Scoutbook. Here’s how:

  1. Go to your Troop Roster page in Scoutbook.
  2. Click on your name.
  3. Click on your Scoutmaster position.
  4. Check the box next to Position Approved.
  5. Click Update.
  6. Repeat the process for your Troop Admin role.
  7. Log out of Scoutbook, then log back in.

My son is having this same issue. Different troop. I don’t think anything has changed on his account or profile. He is currently first class and can view 1st class and below, but gets the same error message when he tries to view the upper ranks he hasn’t earned yet. He only has one BSA account. He’s in an assigned patrol, etc. This is a recent bug/issue.

Hi Sarah,

Thanks for adding your issues also. Our Troop has not been able to do SMC/BORs for 2 weeks now because of this issue and I’ve seen no progress, we went to our local BSA office and this now escalated to the National team?

Any way I’m disappointed with the lack progress as scouts who have completed all the requirements want to be recognized at our Court of Honor in 2 weeks time won’t be able to.

I don’t know how else to get this fixed…?

@NavaidKhan Did you do as Jennifer suggested about to reset your admin position? Then try unchecking and rechecking the position approved boxes for the scouts?

1 Like

Hi Jacob,

I’ve tried that…doesn’t work.

Please see below…no updates thus far.

Daniel Murphy|Thu, 19 Nov, 09:52 (2 days ago)
|to me, Zakir, Ahsan, Mobashshar, Sajid, feroz, zchoudari@gmail.com, Faiz, Imraan, Nasir

I have sent this up to National to help solve this.

Thanks,

Daniel Murphy | Registration Assistant

BOY SCOUTS OF AMERICA
Circle Ten Council
8605 Harry Hines Blvd.
Dallas, Texas 75235
P 214.902.6763

Daniel.Murphy@scouting.org

@NavaidKhan Is the issue with the Scouts trying to access their own Scoutbook advancements? Or with you trying to access their Scoutbook advancements?

All,

We have a similar problem with one of our scouts (132529494) trying to access his Star and higher ranks.

He is showing in Scoutbook on his primary page as not approved, although when I go to his Membership page, it does show approved. I have disapproved and reapproved but this does not resolve the error.

This is only when he is trying to update his own records. I can update his records just fine as Troop Admin.

I have also tried to reset my own Troop Admin as suggested but to no avail.

Thanks,
Tim Monahan

All,

I did just see that another Asst. Scoutmaster gave this Scout a leadership position but did not approve it. I approved it and now the Scout shows approved everywhere (as I expected).

However, he still cannot access his Star and above ranks. The Scout is in good standing with Internet Advancement.

I have disapproved and reapproved the scout multiple times, had him log in using a different device, and had him clear his internet cache (which has resolved minor issues in the past). Still no joy.