Unit Roster Not Accessible in Internet Advancement

When I attempt to either access the unit roster in IA2 or to add Scouts to an event, the unit roster is not available. Instead, this is what I see:

(I get the same “Expression” error when I try to add a Scout or Scouter to an activity.) I have tried using both the mobile app on my cell phone and then accessing it on my desktop and receive the same "Expression: error.

The unit roster is accessible in both Scoutbook and my.Scouting.org.

I am a Key 3 Delegate and the Scoutbook Administrator for my unit.

Yours in Scouting,


Chuck Olson

OA Representative Advisor & Registrar

Troop 463, Sandy Springs, GA


I have similar problems with my folks. Also Im not able to see some events entered in the last month and a half for our folks.

This was submitted on Saturday to the BSA IT folks.

Thank you. We just got back from summer camp and have a lot of data to enter.


I’m getting the same sort of error. It’s able to pull the list of adults, but cannot pull the list of youth members.

Looks like a CORS error trying to resolve advancements.scouting.org; my correlation id is cf917280-d2c8-11eb-8c69-12e2cee4e2e3

I found this because I wanted to log camping and hiking activity from last weekend. I’m on multiple units and this is affecting only one of the units (so far).

Just touched base with BSA IT. The Scoutbook group is aware of the issue and working to resolve.


Any idea what happened?


No, sir. I’m sure I’ll learn more when it is fixed.

The Troop Roster is back but now it will not allow me to add anyone on the roster to an event. What I get instead is this message:

It doesn’t matter if I try to add everyone who attended or enter and save them one at a time.

I have notified the developers.


The same thing happens in Service Hours. When posting camping, there were two individuals, one Scout and one adult in the event and I was trying to add the rest.

For the Service Hours, the event had been created but no one had been added to it.



There is a planned update scheduled for Monday that may fix these. We will post a change log when updated.

The update appears to have solved the issue. Thnak you

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.