Internet advancement adding activity and view roster dissappeared

Our recharter got approved last week and when I went into internet advancement to add an activity for service hours the roster, activity button and more is gone. I am the new scoutmaster for this year and I was an ASM last year when I had the ability to add camping/service hours etc. And it does show I’m one of the key 3 on Do anyone know how I can fix this?

@ChastineCorrea so you cannot see the Roster? on the Left side bar - sounds like a known issue that is being looked at

@ChastineCorrea Could you try this?

  1. Log in at my.Scouting.
  2. Click on “BSA Web Links”.
  3. Click on “Internet Advancement”.

I am the Unit advancement chair for my Troop and I am facing the same issue. When I log in to Internet Advancement it takes me to my profile page. I can not see the unit roster in the left side menu.
Can someone help me with this issue? Thanks.

1 Like

@RinaMahajan it is an issue being investigated - try the steps above Jennifer mentioned

@RinaMahajan Are you selecting your Advancement Chair role in Internet Advancement (upper right corner)?

@DonovanMcNeil ,I tried the above steps, it shows the same.

1 Like

@JenniferOlinger , yes I am selecting Advancement Chair role.

I’m having the same issue. I’m able to enter activities for Pack and Troop G, but not Troop B.

Another issue that’s shown up is the drop down to add participants disappears after adding the first individual. There’s a blank spot where it should be and each individual has to be added one at a time.

I tried what Jennifer recommended but it still doesn’t work. My account for the girls troop and crew works fine.

Same issue for me. In the unit I’m Scoutmaster for gives me access like I’m only a parent. Other units work fine (show roster, recharter, activities, etc.) and works fine and still shows me as Scoutmaster on the unit roster there. The suggestion of logging in to and jumping over from there didn’t change anything for me, unfortunately.

When I click on the account that I’m a scoutmaster for I it noticed that it says Parent/Guardian under my name. Is there away to remove that so it shows scoutmaster instead? I think that might be the reason. I still have separate accounts for each of my sons labeled parent/guardian.

Unless your children are in a different council, you should only need to have one account.

@ChastineCorrea if you are talking about this - it just shows all in a unit

Screenshot 2024-02-09 at 1.46.34 PM

When I put my cursor on the positons role it shows this

I guess I will jump on the bandwagon and say that I, too, am having the same issue. I have an advancement chair and unit admin as my “jobs” and yet cannot see my Troop G roster but can see my Troop B one.

So is this a known issue and is being looked into?

@MelissaVallet @CrystalWorsham @RinaMahajan @ChastineCorrea

A hotfix was applied Friday night that may fix this issue. Please try again.

Unfortunately, it is still not resolved on my end.

It hasn’t changed anything for me either. Only difference I see is it takes me to the roster page on Pack and Troop G, where before it was showing my leader profile first, but I could access Activity Logs and other options in the dropdown menu. Troop B still shows my profile as a parent rather than a Troop B leader and no Activity Log or Roster options in the dropdown menu.