Error Not found - Troop Roster

I am advancement committee chair and since yesterday I am not able to pull Troop Roster. It is showing the following error:

Error Not Found

How can I fix this? Appreciate your help.


In what tool are you getting this error? Without knowing where it occurred there is nothing we can do to help.

I am having the same issue. Yesterday it didn’t show at all. Today I can see the Roster but can’t save any updates.

Internet Advancement. We do not use Scoutbook so this happens when I am trying to add each item directly into Internet Advancment.

I have tried on Google Chrome and Safari browser on Mac. I also have tried on safari on iPhone 12. But I am getting the same error.


What are you trying to do? The BSA has multiple web sites and systems. Without knowing WHERE the error is occurring there is nothing we can do.

I am using Internet Advancement
Roster | Internet Advancement (
on Microsoft edge.
Today I see the Roster but I can’t save anything. I just get Error and an offer to save changes to synchronize later.

1 Like

I am using site. From menu I select BSA web links and then advancment menu. On that page, I am getting the error. Till Wednesday it was working fine

I’m getting the same thing happening with the Error message when I log into Internet Advancement (see screen shot above). If I try to do any advancement reporting, it will just say Error and offer to save the changes to synch later. Glad it’s not just me. Does this have anything to do with rechartering going on? I lost Key 3 access last year around March when they finalized everything with our council, but it’s allowing me to access it, just not do anything. I wouldn’t think that I would be able to do that if I didn’t have the access?

We have reported this to the developers.


im glad its not me, do we know when it will be fixed? as im am trying to enter merit badges amd do an eagle application

Thank you so much! It’s really appreciated!

We do not have any word on when it will be fixed.

As a workaround you can enter the MBs in Scoutbook so you can complete the Eagle app.

I can’t even get to that screen. I get the error message when I click roster. I can’t even see the names of the scouts.

Hello Katherine,
We have found you have to log in to to do your Internet advancement that seems to solve issues for some people, not everyone but some. I hope this is helpful.

Sorry, I didn’t originally see all of the extra the extra responses. We have also found that using Google Chrome is helpful as well.
Also, if you are not a key 3, you may not be able to see any of the Internet advancement items or do any changes to Internet advancement.
I also found that what works one day does not work the next. For me, I live out in the middle of nowhere, and sometimes, it is the amount of service I’m having on that particular day. It is usually resolved the next day; if not, then I make a call to get things changed or try to figure out a fix. My council has been amazing and helped me with the issues of recharter.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.