BOY SCOUTS OF AMERICA

Scouting Forums

Why doesn't SSO work the way it's supposed to?

Hey, how come I need to log in separately to the new forums and my.scouting.org? SSO is supposed to mean that I “sign on” a “single” time to access all those sites in the same session, not just use the same credentials for all of them.

3 Likes

@SteveCagigas,

You should not have to log in to the new forums after logging in to Scoutbook. Are you logging in to Scoutbook with your my.scouting.org ID and password? If not, go to My Dashboard -> Administration -> My Account -> Switch SSO Profile

I am using my my.scouting.org ID and password. Let me log out and retry to see if it makes a difference.

Weird. The first time I tried to log in, it went to the discussions.scouting.org login page. Exiting Chrome, clearing cookies and restarting Chrome, and it didn’t.

Even weirder…Just got the same response when trying to log in on my iPhone w/ Safari. Logged in to Scoutbook, selected “Forums” and had to log into the Forums…

I am having to login to the forums each time on my (android) phone as well.

1 Like

Yep, it’s happening intermittently to me now. Just recurred on my Windows laptop w/ Chrome ver, 69.0.3497.81

I too have had both seamless pass through and stopped at a scouting.org page. I’ve yet to see the pattern, but there are differing behaviors.

I will add that I am posting for the first time on my tablet and was able to go from scoutbook to the new forums without issue. This in no way negates issues that others have but it was a clean slate condition.

I had the same experience - needing to re-log in to My.Scouting after I had already logged into Scoutbook.com with the same credentials.

I verified through a separate post that SSO doesn’t work in iOS when using the Scoutbook as a webapp from the home screen. I was informed this is a “feature” of iOS of not passing along credentials, thus can’t do SSO

SSO is a theory right now - BSA has SO many different platforms that run on my.scouting - and they all are being worked on to make it seamless - 2023 here we come

@SteveCagigas

Do you have cookies disabled? This will prevent SSO from working properly.

So, in the interests of adding to the confusion, I’ve had the following experience:

  1. Signed in to Discourse, open Scoutbook -> sign-on required
  2. Signed in to Discourse, open my.scouting -> no sign-on required
  3. Signed in to Scoutbook, open my.scouting -> sign-on required
  4. Signed in to Scoutbook, open Discourse -> sign-on required
  5. my.scouting -> Scoutbook, sign-on required
  6. my.scouting -> Discourse, no sign-on required

Occurs under both Firefox and Chrome (latest versions) with Feature Assistant Extension running under Windows 7 on two different machines. Cookies permitted for *.scouting.org and *.scoutbook.com.

Under Chrome on Android (no extensions, cookies permitted as above):

  1. Discourse -> Scoutbook, sign-on required
  2. Discourse -> my.scouting, no sign-on required
  3. Scoutbook -> my.scouting, sign-on required
  4. Scoutbook -> Discourse, sign-on required
  5. my.scouting -> Scoutbook, sign-on required
  6. my.scouting -> Discourse, no sign-on required

Have not yet tried:

  • with extension disabled on PC
  • clearing all cache/cookies and trying again

Confirmed that the same SSO credentials work independently at all three sites if I login separately on all platform/browser combos above.