Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

SSO for Scouts

DO Scouts need to do anything about the single sign on with their accounts? Will Scouts have trouble logging in if they do not change anything? I know today I received emails from scouts who can not log into Scoutbook.

Thank you, Connie

When Scouts login for the first time, SSO is handled in the background. They don’t have to do anything.

What system are the Scouts trying to log into? You can give us their member ID (no names needed) and we can look into it.

My son and another scout couldn’t log in yesterday or today got a Whoops error message when trying to log into Scoutbook. The second number below was able to log into his my.scouting account.

Member ID

129644033

127031603

Thank you, Connie

Forcing a refresh in the process seems to get you past it

To force a reset of the webpage:
Enter the address of the page you want to force refresh in the address bar at the top of your web browser. Press and hold Ctrl on Windows or ⇧ Shift on Mac. Holding “Ctrl” or “Shift” can unlock added functionality on your computer keys or desktop icons. Click the refresh button ⟳

Thank you very much!

Thank you, Connie

BSA Id: 127031603 - additional info for Connie’s post,

. https://scoutbook.scouting.org/
2. Select Login Button
3. Login frame opens, enter credentials, Select Login
4. Scoutbook - display error: Whoops! We encountered an error trying to process your request.
Our webmaster has been notified and will fix it ASAP!

Tried incognito window
Cleared cache and hard reset, cleared cookies
Chrome Browser
Edge Browser

Checked Dev tools - Network - all Status 200, did not see any errors. I can try again and capture the SessionId if that would help in troubleshooting.

Tried all your refresh options and still resulted in the Whoops error page.

@SeanKelly - can you try this as a way to get into scoutbook > have youth log into advancements.scouting.org then once that loads, at the left click on scoutbook. That seemed to work for my son’s account.

Stephen H & All
Even after “clearing “ things I still could bot log in. Stephen’s way was successful though.

Anything else we can try?

Thank you, Connie

@ConstanceGonsalves - give this try to see how it works: (just for the scout logon)

log into advancements.scouting.org
go to scoutbook from the prior instructions
once in scoutbook go to my account
copy that url, then close the browser, relaunch the browser and paste that url in, use the login window

This is very frustrating…
so you can log into the scouts account this way but when you try to post a comment or mark off an advancement it gives you the same WHOOPS message.

@ConstanceGonsalves - was able to reproduce that on my son’s account. Bit of an annoying thing.

Sorry for the frustration on this. The developers are looking into it.

I appreciate all the help :blush: the annoying comment was in general not at anyone and I do like Scoutbook just feel helpless sometimes when a scout comes to me looking for help and I can’t.
For now I will have them use a parents account if needed. Thanks again fir looking into things.

Thank you, Connie

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.