Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Still Log in issues

Okay, read through all advise on clearing caches of the browsers and cleared it: not able to log in. Opened a private window to log in and still cannot log into Scoutbook. Only to the the internet advancement and my.scouting.org.
Scoutbook log in screen tells me
“We were not able to log you in. Please refresh the page and try again.”
What other ways/secrets are out there to get back into Scoutbook?

3 Likes

Try clearing your cookies, too.

Open a private / incognito window, and then:

If you are trying to access Scoutbook, the new url is:
https://scoutbook.scouting.org/
Try reloading the page once or twice before you actually try to log in.

If you are trying to access Internet Advancement, the new url is:
https://advancements.scouting.org/

1 Like

Sorry, was not entirely accurate in my description: I cleared caches and all cookies. I have the new URL of Scoutbook and I tried it in a private window in my browser. Scoutbook does not recognize my SSO log in credentials.
I was successful in accessing Internet Advancement, but even when clicking on SB inside Internet Advancement it did not register my log in credentials (I used SSO) for Scoutbook.

Do you refresh the page and try again? Same results? What browser are you using?

Yes, refreshed. Deleted cookies again. Opened new private window, refreshed a few times before trying to log in. Same error message. Firefox is the browser.

Do you have any extensions enabled? You could try disabling them.

Not in Firefox, only in Chrome.

Are you using your my.scouting username and password when you log in?

I am having lots of issues with Scoutbook and Internet advancement too. I got the email and did the steps to “resolve” the issue. No luck. Any update on the status of these issues?

Yes, I am on SSO from the beginning. Get access with that same log in credentials to my.scouting.org and the internet advancement site, but not to SB.

There is a problem with going to Scoutbook from Internet Advancement. I suggest going directly to https://scoutbook.scouting.org/mobile to log in to Scoutbook.

Tried refreshing still doesn’t work. Chrome IOS. It works with my iPad and my Samsung Phone. Not my Mac.

I cannot log into Scoutbook. I tried to reset my password but Scoutbook does not allow me passed the challenge questions! Very frustrating! I have been trying this for several days! Help!

As mentioned above I use SSO which means username and password in my.scouting.org and Scoutbook are identical.

Going from Internet Advancement to Scoutbook through the provided connection was just one way I tried to access Scoutbook in the hopes it wold recognized that I was already successfully logged into IA with the same log in credentials that apply to SB and my.scouting.org. It was not the only way. I also used the direct link.
Sounds like I already tried all ways since I don’t see any new advice on how to make Scoutbook recognize the log in.
Is BSA working on those issues and we just wait and see if things change or is this now how it will be? Any insight on that?

Annette,

What URL are you using to access Scoutbook directly? What browser are you using?

Walter,

Use an Incognito or Private window in your browser with the URL https://scoutbook.scouting.org/mobile Let us know if this lets you log in.

I am a former IT professional, have tried all of these steps and I cannot login to scoutbook by any workaround. Something is broken. Please help. There is no tech support to escalate to, says to ask council for help…

Firefox and https://www.scoutbook.com/mobile/

Annette,

You MUST use https://scoutbook.scouting.org/mobile The URL was changed on Monday. The old URL is supposed to redirect but that is not working properly.

1 Like