BOY SCOUTS OF AMERICA

Scouting Forums

"Your Scoutbook account needs to be connected to a scout as a Parent/Guardian to use the scouting app" Part 2

Afternoon, all,

I am having what appears to be the same problem as was reported in this thread.

I attempted to log into the Scouting app (under Android 9.x) with my my.Scouting credentials, and got the error message:

“Your Scoutbook Account needs to be Connected to a Scout as a Parent/Guardian to use the Scouting App”

I verified that I still appear to be connected to my son as a parent in Scoutbook. I went into my positions via the My Dashboard -> My Units -> Troop Roster -> My Name, and Updated all of my positions (last one in the line was Troop Admin). Then, went to my connection to my son via My Dashboard -> My Family and Updated my connection to him there. The app still throws the same error.

Any other thoughts on what to try before I submit a bug report?

try Unit > Scout > click parent there and update

also try reentering your credentials if they are saved - in the APP that is

No joy.

Nope. Credentials not saved. Also checked spelling to be sure.

Are there any restrictions on passwords in the app that might not apply to my.scouting in general (e.g. limits on special characters are different, etc)?

no it is the same SSO requirements - sounds like your connection got messed up (wish we could figure out what is causing that) - I sent you a direct message

I am having this issue as well. I am connected to my son (cub) and listed as a parent on Scoutbook website, but cannot log in through the app as it says I’m not connected.

Hi, @ChristopherSummer,

Can you also submit a bug report to scoutbook.support@scouting.org? You’ll want to give them any information about when you started having the problem, your scoutbook login information, the scout you’re supposed to be connected to but that isn’t showing up in the Scouting app at login, what platform you’re on (ios, Android) and the version of the app you’re running.

You can also copy scoutbookappsupport@scouting.org. @DonovanMcNeil is pretty sure it’s a scoutbook issue, but just in case, it’s probably good for the folks managing the Scouting app to be aware that this issue is cropping up, in case they are aware of a recent change to the code in the app that might interact with verifying the credentials/connections from Scoutbook.

As far as I know, they’re still working on identifying the problem/solution, since I still can’t access the app either as of just now.

Also, if you post the SSD number that appears in the subject line of the auto reply to this forum, the SUAC can help the developers associate the bug report with the issue so they can pool the information.

So, I have new data. When my wife logs in to the app, my name appears as one of the parents. However, I still can’t log in.

Multiple accounts? I thought we already had that sorted out before. I tried logging in to the app with my email address (used @ Scoutbook prior to the SSO implementation), but got invalid username or password. Thoughts?

ETA: Oops. Broken link. Snapshot posted directly in lieu of link.

The last time I ran across this issue with a parent in my troop it was because they had two different BSA IDs. The scout was dual-registered in our troop and a crew, and the parent was on the committee for both units, but one of them registered her new instead of making her dual-registered with the other unit. She was in Scoutbook twice, once as a troop committee member and the other as the parent of the scout. Fixing it involved getting her to email the national service center and getting them to merge her two BSA IDs (and MyScouting accounts).

Yeah, I just can’t figure out why I would have yet another new BSA ID. I’m only registered with one unit, and my.scouting shows both of my known BSA IDs on the account (with the correct one current).

I’m starting to wonder if some intermittent background process is creating new BSA IDs for adult leaders for some reason…

There is something else going on. The developers are investigating.

1 Like

I’m not sure if the intent was that the latest update to Scoutbook addressing corrections where parent accounts were not showing up as linked to their scouts was expected to fix this issue. Just in case, I tried logging in to the Scouting app after seeing @edavignon’s Bug Fixes post. Unfortunately, the app (not scoutbook.com) still thinks my credentials don’t associate with my son.

Charley,

We have been told this is a different issue, not related to the parent/guardian connection issue.

Gotcha. Just wanted to follow-up in case the fix was thought to be done. :wink: Thanks for keeping the fires burning, y’all.

So, on the topic of keeping things going, I updated the app this evening to v1.4.6 (Android) which includes the following “What’s new” items:

  1. SBM-1264 Fix Login navigation in landscape mode for android
  2. SBM-1282 Fix attendance no longer showing
  3. Fix rank image changing while navigating through rank details view
  4. Skip parent/scout scoutbook role type check to access the app

Sadly, Item #4 doesn’t seem to be working in the expected manner. After installing the update, I get a new error:

“Sorry, unable to get user role. Please try again later.” I tried a couple of times, and eventually got the original answer again:

“Your Scoutbook Account needs to be Connected to a Scout as a Parent/Guardian to use the Scouting App.”

Looks like Item #4 isn’t quite working.

I have passed this on to the app development team.

1 Like

I am having the same issue with my andriod phone.

It looks like version 1.4.7 (released today) fixed my problem. I suggest that all take a look at the app update to see if it fixes yours.

Also, now that I’m in, I see that if you’re a leader it links to your my.scouting training records under Profile, so you can easily see what training you’ve taken and when it expires. Way better than going to my.scouting to track. It doesn’t tell me if I’m trained (yet!).

Thanks to all on the dev side who’ve been chasing this issue down!