Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Accessing "needs purchased" report - takes me to dashboard?

I’m assisting a Crew Adviser who has full admin rights and is trying to access the “needs purchasing report”. When he does, it takes him back to the dashboard. This also happens with the “needs awarding report”. Appears to be a infinite loop we can’t get out of. The crew is working on Scouts BSA requirements in addition to Crew advancement. We’ve validated his position via his profile and checked the box “position approved”.

Instead of going through his profile, he should go to the Crew roster, click his name > his positions > Crew Admin. Click update without changing anything. That can sometimes reset things.

just completed the outlined task. Tried to access reports and goes back to dashboard. Repeated the task again and logged out and then logged back in. Still no change. Continues to direct us back to dashboard. Same thing happens from the dashboard when we try to use the reports.

I’d check the current membership of all Crew members to see if any have a current membership in a Cub Scout Pack.

Is this happening with everyone or just the Crew Advisor? If it is just the advisor, another admin should go to the Crew Roster -> Connection Manager and verify the advisor is connected to all Scouts with full control. Admins are supposed to be connected but we have seen situations where they are not.

If the advisor is not connected with full control, click on his name and select Full Control. This should reset all the connections.

Can’t speak to everyone. I’ve been working with them to become acclimated with the system. The crew adviser had lots of issues with his profile/account but we sorted all of those issues out. Everything else seems to work except for this last issue. He is connected with Full Control. we just went through and verified all current membership is with the Crew. A few of the boys are associated to 2 crews.

Is this crew advisor a leader in another unit? There have been issues in the past with being an admin in one but not another with accessing reports.

Yes, he is the Advisor for Crew 230 but just a Committee member in Crew 42.

Did he successfully complete “needs approval” and was able to approve? If I don’t have anything to purchase it kicks me from the pack to the troop where I am also a leader.

Yes, he successfully completed all of the items on the “needs approval” report. But can’t get to the next step.

@ThomasSteckbeck - here is something to look at, are there items that need approval/purchasing in the other unit (Crew 42), if so can they be approved and moved to a PO ?

look at one of the items on a scout profile page. Did he happen to mark it awarded at same time?

I reviewed all of the advancement details on all youth associated with Crew 230. All Scout BSA requirements were completed and approved in proper sequence. None were awarded. When reviewing the awards details, I found some where he approved the requirement on 1/14/20 but didn’t actually complete it until 1/15/20. Half of these were out-of-sequence. He only has viewing rights to Crew 42. I will go ahead and end the association with Crew 42. We can also reinstate after the fact.

We have verified the roster and it is correct. we’ve approved all advancement that was completed and verified that nothing was prematurely awarded. We allowed the system to sync since Friday. The problem still exist. When clicking on “needs purchasing report” or “needs awarding report” we are directed back to the dashboard. We ended his association with the other Crew where his is just a Committee Member; did that on Friday. We have verified that he has full control of all youth on the roster. Still unable to generate a PO to complete this process.

Can you please clarify how the above quote squares with the leader’s inability to get to the needs approval report?

Separately has he been able to mark any requirements complete with the approved box checked since this problem initially started?

look at the unit roster and click on this user from your account > go to their profile page > look at the URL and get the UserID= and post that here.

UnitID=204033&DenID=&PatrolID=

I believe this is what you need AdultUserID=4945308&UnitID=204033

OK I logged on as him on test server and yes the account seems messed up some how. I do not even see Needs Reports. Send an email to scoutbook.support@scouting.org. Include the UserID= tell them it seems that the Admin position is not functioning correctly. Include as many details as you can.

Post the ticket number here when you get it

@ThomasSteckbeck one thing I found on the test server I can fully process the reports from that account if I click on reports from My Dashboard, just not from Unit