Add Leader user search returns no results

When trying to add a registered adult as a leader I am selecting the Add Leader button on the Roster. This takes me to the Add New Leader page.

I have tried searching using the adult’s name and BSA ID# and no results are returned. I tried using my name and BSA ID# and no results are returned. I tried with several other adults that are already leaders and they are not returned, either by name search or BSA ID#.

The adult I am trying to add shows that she is an Adult Leader in her profile. I know I’m an adult leader because I’m currently Committee Chair and appear in the list of leaders. Yet the search cannot find me using my BSA ID#.

Is this a known issue? Is there a workaround to allow us to add this adult as a leader as she is Treasurer and needs permissions to do her job?

@StephenAbbott what is the BSA#?

If you are already a leader in the unit in scoutbook the system will not find you as you are already in the unit.

Do you see the adult listed as an adult leader on the unit’s Roster at my.scouting? (But not Lion or Tiger Adult Partner, which are not considered registered adult leaders by the BSA)


As Donovan said, if you provide the BSA # (no names) we can look it up to see if the individual is registered. Only individuals registered with the BSA are eligible to be added to the roster as an adult leader.

The unit treasurer is a committee position so the individual should be registered with your unit as a Committee Member.

@StephenAbbott - it seems to me that you are trying to add roles to existing leaders or am i misunderstanding the purpose ?

I checked on and apparently even though we rechartered months ago and submitted an adult leader application for this person at the same time they still haven’t updated her in our roster to be an adult leader. They were quick to cash our check though.

I will have to call the local council office and find out why this hasn’t been done since they’ve had ample time to take care of everything.

One thing that I find annoying is I just tried all of the steps that I did previously, and I am now being returned in the search results if I put my BSA ID# in. Before it wouldn’t return anyone, even adult leaders who are in other units who could conceivably be leaders in our unit as well. Now it’s working, with no reason why. It apparently doesn’t check if you are already a leader in the unit you are using the search for, but it also apparently doesn’t work consistently. I’ll need to remember that in the future, shutting down and restarting to see if the search is working.

Not necessarily the same cause as your issue, but I noticed that I had “lost connection” to the scouts I was connected to in Scoutbook as a MBC. I assume it was due to the registration grace period expiring on 31 March (which disconnected me). The subsequent extension of the grade period resulted in my MBC position persisting, but all of my connections were broken. I wonder if the same issue was hitting the search feature when you tried it, and the extension of the grace period hadn’t hit yet when you were trying before.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.