Add new leader search not working

I’m in charge of our Pack’s scoutbook and this year when I try to assign den leaders the search isn’t finding anyone. It keeps saying no results regardless of how much detail or how many fields I populate. This happens no matter which leader position I try to fill even if they already have positions. As a workaround I tried the link to the application page but it leads to a page where it says I do not have access. Please assist. Patowatami - Pack 49

@AndrewMeyer3 - are threy listed on the roster at

1 Like

A couple of questions to help get things rolling.

I’m assuming you’re a Scoutbook unit admin. If so, have you tried going to My Dashboard → Administration → My Units → Unit Roster → your name,

then clicking your Unit Admin role, reapprove it, then hit save? Sometimes the position looks like it’s correct, but it’s gotten goofed up behind the scenes at some point. This is path-dependent, so only the steps outlined will make the “fix”.

Second question, has someone with access to your roster at (like Key 3) verified that the DLs are all registered as such? We’ve had issues where registration dropped for no visible reason.

Thanks for fast responses! I followed the re-approval process and I am able to add leaders now. There was still one person who it couldn’t find that is to be an Ass Den leader for bears but I don’t have access to our roster in so I’ve reached out to our Pack Master to look into that one account. Thank you so much!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.